Sometimes Connected but no internet

Hi,

I have an issue with a OpenWRT in AP WiFi (no firewall, no DHCP, no dnsmasq).

Sometimes I have a message "Connected without internet" on a device (Android, Windows, etc...). And after few time (> 5mn), the connection begin to be good. But Sometimes I haven't any issue... It's fully random.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdde:7a6a:db90::/48'

config interface 'lan'
        option type 'bridge'
        option delegate '0'
        option proto 'dhcp'
        option ifname 'eth0 lan1 lan2 lan3 wan'

config interface 'lan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'no'
        option ifname '@lan'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'
        option type 'bridge'
        option reqaddress 'try'
        option reqprefix 'auto'
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'HT20'
        option channel '8'
        option country 'FR'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'FR'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'XXX'
        option encryption 'psk2+ccmp'
        option key 'XXXX'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'XXX'
        option encryption 'psk2+ccmp'
        option key 'XXXX'
        option network 'lan'

The only visible problem is the multiple bridges you have with the same interfaces. Physical interface wan is in uci interface lan and wan and both have dhcp protocol. Delete uci wan interface or remove wan physical interface from lan uci interface.

1 Like

Thx !

Like that:

 cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdde:7a6a:db90::/48'

config interface 'lan'
        option type 'bridge'
        option delegate '0'
        option proto 'dhcp'
        option ifname 'eth0 lan1 lan2 lan3'

config interface 'lan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'no'
        option ifname '@lan'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'
        option type 'bridge'
        option reqaddress 'try'

Better now. Also the bridge in wan and wan6 is not necessary, you can remove it as well. See how it goes now and let us know if it is solved.

Thx !

I doing:

uci del network.wan.type
uci del network.wan6.type
service network restart

I have now:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdde:7a6a:db90::/48'

config interface 'lan'
        option type 'bridge'
        option delegate '0'
        option proto 'dhcp'
        option ifname 'eth0 lan1 lan2 lan3'

config interface 'lan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'no'
        option ifname '@lan'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.