Something blocking

Can anyone explain why OpenWRT/LEDE won't resolve for me?
LEDE won't resolve it, but the ISP's DNS server will.
Here's what I observe: ( is my ISP's DNS server)

$ nslookup

Default Server:

Non-authoritative answer:

Default Server: router.home
Server: router.home

*** router.home can't find Non-existent domain

Here's my system:
Hostname LEDE
Model Linksys WRT3200ACM
Firmware Version Lede Reboot SNAPSHOT r4114-6704410 / LuCI Master (git-17.130.58552-d04f667)
Kernel Version 4.9.20

My google searches on this topic find hits about various "adblock" software and features, but I don't see any evidence of any such thing installed in this router, nor configuration files that might black list such names. Same problem with, btw.

I guess you are running one of @davidc502's builds... are you sure it does not come pre-configured to block adds, or use some OpenDNS or similar service?

Yes, this is one of @davidc502 's builds.
I don't see any indication that there's any add blocker.
What might I look for to check? Thx.

In LuCi Under > Services > Adblock , make sure it is disabled (Unchecked).

Also, is the router configured to use your ISP's dns?

Oh, so there it is! Thanks.
Funny, I only looked around in /etc and didn't see anything about it.

So if I later decide to turn this back on, can I "white list" the
couple sites that google search results often use?
Otherwise you can't click through to results...

I've never used adblock, so I don't know its configuration capabilities. However, I've read that it is highly configurable, so white listing should not be a problem.

The whitelist is located in /etc/adblock/adblock.whitelist

i am prettey sure you don't need a connection to the ads-domain to use search.
bonus points: if you load google-search w/o .js you get real/direct hyperlinks.

try ublock origin!
your browser/client should decide what gets displayed, not your network.