Some issues with my TP-Link Archer Ax23 v1.2 (US)

I installed OpenWRT version 23.05.3 (the latest version) and also tried the latest snapshot version for the TP-Link Archer Archer Ax23 v1.0. I have tries both the product page and the firmware selector
My router is the v1.2 US not v1.0 (but the product page states that the v1.2 is the same, I think not really), and when I installed both of those builds, I still get this same issue:

Product Page:
https://openwrt.org/toh/tp-link/archer_ax23_v1

OpenWRT firmware on my TP-Link Archer Ax23 v1.2 (US) using the v1.0 firmware (which is the only available one):
100-200MBPS fluctuating Download and 350MBPS over WIFI 5GHZ (Just
while beside the router)
500MBPS Upload and Download over Ethernet

Stock TP-Link Router
350MBPS Download and 350MBPS over WIFI 5GHZ (Just
while beside the router)
500MBPS Upload and Download over Ethernet

Why does OpenWRT lowers the Wifi download speed but not the Upload Speed? Driver issues?

Config:
I tried every 5ghz channel. I set 80GHZ for AC (I don't have AX/Wifi6 devices though to test that). What's going on?

I tried turning on Hardware and Software offloading, still the same.
I tried installing and enabling irqbalance, still the same.

The ethernet is fine with OpenWRT.
The WIFI 2.4 GHZ@40MHZ and 20MHZ seem to be slow also (like 20MBPS upload-download compared to stock firmware having 50MBPS upload-download, I am just beside the router).I checked for interference but the other networks are far from my channel.
The WIFI 5GHZ AC@80MHZ is fine with Upload speeds but the Download Speeds are terrible and slow. But Ethernet is actually better in OpenWRT but Wifi is super terrible.

Is that because my hardware is version 1.2 (US) and not 1.0? I searched thoroughly in the firmware selector but no firmware for the actual v1.2

"The device is sold as hardware revision v1.20 in certain regions but is identical and can be flashed with OpenWRT as well."
Yes, but why does the performance on the v1.2 it is slow. I am not using a v1.20 AX23. I am having the v1.2 (US). Not v1.20 or v1.0, it is v1.2.

So for now, I retreated back to the stock firmware. I will return back to OpenWRT if someone can help me fix the WIFI issue.

I am talking about Wifi 5 (AC) at 80MHZ and Wifi 4 (N) at 20MHZ or at 40MHZ.
But my main concern is the AC download speeds. But I want to also address the Wifi 4 download and upload speeds for my older devices though.

For now, I don't care about AX speeds because I don't have devices that support it.

#1 you actually read the product page.

However, I cannot find where it says v1:

Please help me help you by quoting where it it said.

https://openwrt.org/toh/tp-link/archer_ax23_v1
Right there on the top

So sorry:

Of course I'd miss the first paragraph.

Allow me a moment to figure out what I can.

Please disregard these 10 words I must write to post.


        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:4",
        "model": "TP-Link Archer AX23 v1",
        "board_name": "tplink,archer-ax23-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '1**.0.0.1'
        option netmask '2**.0.*.0'

config globals 'globals'
        option ula_prefix 'fd9d:a000:3b10::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'


config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel 'auto'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Extra'
        option encryption 'sae-mixed'
        option key 'j'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel 'auto'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Extrag'
        option encryption 'sae-mixed'
        option key 'j'


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'


config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

In LuCi, let us start with:
Network/Wireless ->edit-> Advanced Settings; set your country on all radios.

then reboot.

1 Like

It is now set to my country code Philippines (PH), Still the same.
221MBPS Download and 344MBPS Upload via WIFI 5GHZ@80MHZ with a ping of 6ms (Just beside the router).
For Ethernet: 412.87MBPS and 411.41MBPS over Ethernet (6ms ping)

Pick an encryption; OpenWrt does not play nice with mixed .

WPA 2 only gives 258MBPS Download but still higher upload of 348MBPS. I want it to still reach atleast 340MBPS.
Now set to WPA2 only.

Forgive me if I need to ask:
What are your stats now with WPA2?

The one I mentioned here. Sorry for my unclear reply. I use WPA3/WPA2 mixed before, now I use WPA2 only and it still almost the same.

WPA 2 only gives 258MBPS Download but still higher upload of 348MBPS. I want it to still reach atleast 340MBPS.
Now set to WPA2 only.

I'm going to need to search this.

Please allow time.
Anyone is invited to jump in.

1 Like

Enable offload

I enabled it both Hardware and Software ones but sadly it is still the same.

The issue was that the stock firmware's download speed on 5ghz wifi is faster but it's upload speed was the same as stock firmware. Don't know this is happening. The reason I installed OpenWRT is to control my router like just turning on a single light and disabling everything else (just to know if the WAN is connected).

I suspect that there is something miserable happening either on the firmware or on the drivers itself (I think the hardware of my v1.2 is not the same as the v1.0).

But for now, I'll stay with OpenWRT and will wait for the community's help to stablize the 5ghz download speed.

And lone soft offload?

Sadly, disabling hardware offloading and letting software offloading on does not do anything. While disabling offlloading altogether is the same

For now, I surrendered using OpenWRT and reverted back to stock firmware. In the future, I hope that OpenWRT would be fine on my device soon.

I will reconsider using OpenWRT again if someone can point out what is happening on my situation. I was impressed by OpenWRT but the Wifi problem makes me sad.

1 Like