Some devices don't see Wireless Network

Some devices can easily connect to my wifi network, but some smartphones and laptops are unable to even see the network (to select it for connecting). I tried changing the operating frequency as this caused some trouble in the past, when the Channel was set to 'auto'. I don't know where to start troubleshooting.

|Hostname|OpenWrt|
|---|---|
|Model|TP-LINK Archer VR200v|
|Architecture|xRX200 rev 1.2|
|Target Platform|lantiq/xrx200|
|Firmware Version|OpenWrt 23.05.2 r23630-842932a63d / LuCI openwrt-23.05 branch git-23.306.39416-c86c256|
|Kernel Version|5.15.137|

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# ubus call system board
{
	"kernel": "5.15.137",
	"hostname": "OpenWrt",
	"system": "xRX200 rev 1.2",
	"model": "TP-LINK Archer VR200v",
	"board_name": "tplink,vr200v",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.2",
		"revision": "r23630-842932a63d",
		"target": "lantiq/xrx200",
		"description": "OpenWrt 23.05.2 r23630-842932a63d"
	}
}

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option ds_snr_offset '0'
	option annex 'j'
	option tone 'bv'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'dsl0.7'
	option macaddr 'xxxxxxxxxxxxxxxxxxx'

config interface 'wan'
	option device 'dsl0.7'
	option proto 'pppoe'
	option ipv6 '1'
	option username 'xxxxxxxxxxxxxxxxxxx'
	option password 'xxxxxxxxxxxxxxxxxxx'
	option mtu '1492'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
	option band '5g'
	option htmode 'VHT20'
	option cell_density '1'
	option country 'DE'
	option channel '161'
	option txpower '0'
	option distance '10'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'XXXXXXXXXXXXXXX'
	option encryption 'sae-mixed'
	option key 'XXXXXXXXXXXXXXX'
	option wpa_disable_eapol_key_retries '1'
	option isolate '1'
	option wmm '0'
	option macaddr 'random'


root@OpenWrt:~# cat /etc/config/dhcp 

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option confdir '/tmp/dnsmasq.d'
	option serversfile '/var/run/adblock-fast/dnsmasq.servers'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall 

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'
	option drop_invalid '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'





I do not know why OpenWrt allowed 160 but this page says you are outside Germany's channel limit of 140.

changed it to 140, but does not solve the issue

Reboot it and give it a minute or two to complete its clear channel check for DFS.

Do not use sae-mixed encryption. This tends to cause problems with many devices. Use WPA2 or WPA3, but not mixed mode. (if your devices don't all support WPA3, try with WPA2).

Remove these lines as well:

It makes APs invisible?

No, it doesn't make them invisible (there is another option for that)... it does cause compatibility issues with some devices which simply won't be able to see or connect to the SSID properly.

1 Like

did all, still not working

Let’s see the latest configs.

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
	option band '5g'
	option htmode 'VHT20'
	option cell_density '0'
	option country 'DE'
	option channel '64'
	option txpower '0'
	option distance '5'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxxxxxxxxxxxxxxxxx'
	option encryption 'psk2'
	option key 'xxxxxxxxxxxxxxxxxxxx'

try changing the channel to 36.
Remove the
remove these lines:

And also remove this line:

What specific devices are having trouble connecting?

Actually it can even make the AP invisible to some devices, I've seen that in the past with an android device. Some devices get really confused about anything that doesn't exactly fit their expectations and they're designed so badly that even optional (opt-in) features that shouldn't affect it at all can wreak havoc. This typically affects smart/ IoT devices (phone, printers, anything IoT) more than real computers (which typically have better wlan chipsets and much better tested/ updated drivers).

2 Likes

Just for a minutes or two, in addition to @psherman's suggestion set everything to default disable, security (remove the password too) and set the channel to Auto..

Lets see if it is a config issue; if they start to see the AP we will add them back one at a time.

Tried all of your suggestions. When setting the channel to 64 not even my phone detected my network, also when no password was set. Setting it to auto chooses 104, which works for my phone, but not my laptop with a Qualcomm Atheros QCNFA222 WiFi 802.11a/b/g/n.

That page might be outdated. In Europe, channels 144-173 are available under the SRD (Short Range Device) allocation. DFS is not required, but power is limited to 25 mW / 14 dBm EIRP.
https://en.wikipedia.org/wiki/List_of_WLAN_channels
https://www.heise.de/ratgeber/WLAN-Kanaele-von-149-bis-161-und-von-165-bis-173-legal-nutzbar-7467072.html