Some devices cannot connect via wireless

I have installed OpenWrt 18.06.1, r7258-5eb055306f on a bt home hub 5. My internet connection is fibre to cabinet and my provider does not support ipv6.
I can connect on a variety of devices (laptop [windows and linux], hudl2 [android], now TV stick) via wireless and also wired to the internet from my laptop BUT I cannot connect from a number of other devices (android phones and also a desktop pc [via wireless - haven't tried wired to this]).

I have tried a few things based on solutions posted on forums in the past for problems with android (disabling ipv6 and configuring dns server addresses) but to no avail.

I don't think it is an android issue as such - as the hudl connects and the desktop does not. Note that all the devices connected fine with the same router running internet provider firmware.

Any ideas of how to sort this and what the problem could be ?

The etc/config files that have been altered from stock are as shown below.
network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '<2bytes>:<2bytes>:<2bytes>::/48'

config dsl 'dsl'
	option tone 'a'
	option ds_snr_offset '0'
	option annex 'a'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.254'
	option netmask '255.255.255.0'
        option ipv6 '0'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '<macaddr1>'

config interface 'wan'
	option proto 'pppoe'
	option username '<username>'
	option password '<passwd>'
	option ifname 'dsl0.101'
        option ipv6 '0'
	option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr '<macaddr2>'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'
	option type 'bridge'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config interface 'wwan'
	option proto 'dhcp'
	option type 'bridge'

dhcp:

config dnsmasq
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	list server '8.8.8.8'
	list server '8.8.4.4'

config dhcp 'lan'
	option interface 'lan'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option limit '150'
	option leasetime '12h'
	option start '64'
	list dns '2001:4860:4860::8888'
	list dns '2001:4860:4860::8844'
	list dhcp_option '6,8.8.8.8'
	list dhcp_option '6,8.8.4.4'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
	option country 'GB'
	option legacy_rates '1'
	option channel '36'
	option htmode 'VHT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key '<key>'
	option network 'lan'
	option ssid '<ssid>'
	option macaddr '<macaddr>'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:0e.0'
	option country 'GB'
	option legacy_rates '1'
	option htmode 'HT20'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option key '<key>'
	option mode 'ap'
	option ssid '<ssid>'
	option macaddr '<macaddr>'
	option encryption 'psk2+ccmp'

firewall:


config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'
	option masq '1'
	option mtu_fix '1'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 wwan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'
	option enabled '0'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'
	option enabled '0'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'
	option enabled '0'

config include
	option path '/etc/firewall.user'

Checking the MAC addresses of the "problematic" devices and looking at the logs for those MAC addresses, would be my suggestion.

1 Like

At what phase of the connection do they fail?

  1. Do they find the SSID?
  2. Do they connect to the AP?
  3. Do they get IP/MASK/GW/NS?
  4. Somewhere else?
1 Like

I think they connect to the AP but no internet.
What I have noticed is that on the luci wireless page I do see connected devices but unlike the ones that have internet connections they have a que (or it might be the dhcp tab there is a question mark for the hostname for unconnected devices but I do see IP addresses. Not sure how to check the other items in 3.

What logs in particular ? Its hard to know where to start looking and what to look for.

First enable the debugging in DHCP.: Network -> DHCP and DNS
Then Advanced Settings tab, untick the Suppress logging, Save and Apply.
View the logs logread -f | grep dnsmasq
and have some problematic client trying to connect.
Let us know what is the mac and/or hostname of the problematic client in case the log is full with different entries.

Thanks Trendy and Jeff. Looking at the logs for the problematic devices helped narrow it down and forced me to discover a silly error in setting up wireless - on the luci wireless page I could see the problem device only popping up on one frequency. Suddenly it all made sense - it was the newish devices that were connecting because they could use 5GHz all the problem ones were single frequency and the 2.4GHz radio in the router was not connected to the LAN! It was as simple as that.
Thanks again.

4 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.