Some annoying opkg errors?

this is unbelievable
i downloaded 18.06.1 stable ar71xx sysupgrade firmware
flashed using mtd
i can ping domains and it works
why do i have to spend hours and hours to just this opkg shit

Downloading https://downloads.openwrt.org/releases/18.06.1/targets/ar71xx/generic/packages/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/releases/18.06.1/targets/ar71xx/generic/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/base/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/base/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/luci/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/luci/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/routing/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/routing/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mips_24kc/telephony/Packages.gz

the first line i changed to https because http gets 404
since i can't update it how the hell i can install sssl?

and where can i find packages?
https://downloads.openwrt.org/releases/18.06.1/targets/ar71xx/generic/packages/
this must be no brain.

i know i must be dong something wrong but this shit is way too annoying.

The server was probably down for a short while, it works for me using http. You can also wget the ssl package and ca-bundle to tmp without https and install manually.

Sorry, i wrote too quickly, not noticing the manual http-->https edit.

Like Per says, probably the server was just down, or alternatively, you had some DNS problem or so.

where is the link to donate?

i spent 8 hours for nothing.

so the server is down even chaos calmer

Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ramips/mt7620/packages/base/Packages.gz.
wget: can't connect to remote host (81.0.124.218): Connection timed out

damn it!!!!

@hnyman, @skveen just reported something similar....

That's not the IP on this side of the globe...

lleachii@machine:~$ nslookup downloads.openwrt.org
Server:		127.0.0.53
Address:	127.0.0.53#53

Non-authoritative answer:
downloads.openwrt.org	canonical name = mirror-01.infra.openwrt.org.
Name:	mirror-01.infra.openwrt.org
Address: 148.251.78.235
Name:	mirror-01.infra.openwrt.org
Address: 2a01:4f8:202:43ea::2

isn't it one of the mirror?
are you sure?

or am i hacked?

whois 81.0.124.218
% This is the RIPE Database query service.
% The objects are in RPSL format.
%
% The RIPE Database is subject to Terms and Conditions.
% See http://www.ripe.net/db/support/db-terms-conditions.pdf

% Note: this output has been filtered.
% To receive output for a database update, use the "-B" flag.

% Information related to '81.0.124.0 - 81.0.124.255'

% Abuse contact for '81.0.124.0 - 81.0.124.255' is 'abuse@invitel.net'

inetnum: 81.0.124.0 - 81.0.124.255
netname: DEPLOYIS
descr: Deploy Is Kft.
country: HU
admin-c: AG15638-RIPE
tech-c: VINO2-RIPE
status: ASSIGNED PA
mnt-by: AS12301-MNT
created: 2012-11-16T15:03:15Z
last-modified: 2012-11-16T15:03:15Z
source: RIPE

role: INVITEL IP NETWORK OPERATION
address: INVITEL Zrt.
address: H-2040 Budaors
address: Edison utca 4.
admin-c: VINC1-RIPE
tech-c: JS6489-RIPE
tech-c: IOS2-RIPE
nic-hdl: VINO2-RIPE
abuse-mailbox: abuse@invitel.net
mnt-by: AS12301-MNT
created: 2001-12-12T11:17:58Z
last-modified: 2016-04-01T21:35:16Z
source: RIPE # Filtered

person: Andras Got
address: Deploy Is Kft.
address: H-1032 Budapest
address: Agoston u. 2. IV. em. 20.
phone: +36 30 3407298
nic-hdl: AG15638-RIPE
mnt-by: AS12301-MNT
created: 2012-11-16T15:03:15Z
last-modified: 2012-11-16T15:03:15Z
source: RIPE

I've only found only one reference on the Internet related to this IP...and I began to find it odd that out of these two threads, and the one I found...2 mention Chaos Calmer...all three share in common...it's an issue with an older OpenWrt version.

https://foro.seguridadwireless.net/openwrt/actualizar-paquetes-de-openwrt/

Have you tried using one of the mirrors explicitly? https://openwrt.org/downloads#mirrors

I just removed the German mirror from the mirrors list because there is no lede or openwrt directory there. Maybe it has just been removed, and that's why some people get an error?

Per i appreciate your help and cares..

that wiki link again pissing me off.

  1. openwrt doesn't come with rsync
  2. that manual is also no brain
    rsync://downloads.lede-project.org/downloads and then what??

looks like all of archive downloads are went off.
someone really need to make opkg solid.
nevermind even apt can't manage itself sometimes.

thank you for help everyone.
btw, where is the link to donate these organizers?

There are also http, https and ftp links for various sites. You are supposed to use those with the appropriate subpath in the repository file. There is no system for donations. Donations page

1 Like

Could you elaborate how to configure mirror list in busybox?

I haven't tried it myself, but I assume it will work if you replace http://downloads.openwrt.org/ with for instance http://openwrt.tetaneutral.net/ (one of the French mirrors) in /etc/opkg/distfeeds.conf

v17 v18 works here too
just all archive links are dead.
even your mirror too.

I suggest you download the files needed to use https to a PC using https and scp them to the router. If at all possible you should upgrade it to 17 og 18 for security. 15 hasn't been maintained for ages.

Per, I thank you for your efforts. I understand it isn't much used however, I finally found the working official mirrors and all versions are here at https://wiki.openwrt.org/about/mirrors
Thanks again.

Likely just a temporary server outage...
http://lists.infradead.org/pipermail/openwrt-adm/2018-September/000896.html

1 Like