[Solved] ZTE MF286D running OpenWRT - problem LTE connect

Hi, today I managed to flash my ZTE MF286D Router with OpenWRT 23.05.2 :slight_smile: Thanks for all the great docs and tutorials - great work.

Actually I am running the router over WAN Port in my network:

  • Router 192.168.0.x
  • Network 192.168.1.x

So I have internet over WAN port and got everything up-to-date. No to my question, I have Telekom (Germany) SIM card in slot and setup the "QMI Cellular" like described in the docs and provided by Telekom:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda0:dff0:3a17::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config interface 'lte'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn 'internet.v6.telekom'
	option pdptype 'ipv4v6'
	option auth 'none'

I also tried entering user/password and also SIM PIN... which does not changed anything :frowning: There is no LTE connect and the following logs:

> Fri Feb 23 19:07:33 2024 daemon.notice netifd: Interface 'lte' is setting up now
> Fri Feb 23 19:07:33 2024 daemon.notice netifd: lte (11868): Waiting for SIM initialization
> Fri Feb 23 19:07:34 2024 daemon.notice netifd: lte (11868): Failed to parse message data
> Fri Feb 23 19:07:34 2024 daemon.warn odhcpd[1477]: No default route present, overriding ra_lifetime!
> Fri Feb 23 19:07:34 2024 daemon.notice netifd: lte (11868): PIN verification is disabled
> Fri Feb 23 19:07:35 2024 daemon.notice netifd: lte (11868): Device does not support 802.3 mode. Informing driver of raw-ip only for wwan0 ..
> Fri Feb 23 19:07:35 2024 daemon.notice netifd: lte (11868): Waiting for network registration
> Fri Feb 23 19:07:37 2024 daemon.notice netifd: lte (11868): Starting network lte
> Fri Feb 23 19:07:37 2024 daemon.notice netifd: lte (11868): Unable to connect IPv4
> Fri Feb 23 19:07:37 2024 daemon.notice netifd: lte (11992): Stopping network lte
> Fri Feb 23 19:07:37 2024 daemon.notice netifd: lte (11992): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "lte" } (Permission denied)
> Fri Feb 23 19:07:37 2024 daemon.notice netifd: Interface 'lte' is now down

Does anyone has an idea wwhat to check and do next?

PS: I have tried the SIM inside of this router before flashing OpwnWRT and it worked out-of-the box without entering any APN, PIN or user/password... and I also updated to the original firmware to the latest nordic-b12.

Thank and best regards
waywit

Change to ipv6

Thanks... but I think I have already tried this :frowning: ... so I did it again:

Fri Feb 23 19:26:53 2024 daemon.notice netifd: Interface 'lte' is setting up now
Fri Feb 23 19:26:53 2024 daemon.notice netifd: lte (17468): Waiting for SIM initialization
Fri Feb 23 19:26:54 2024 daemon.notice netifd: lte (17468): Failed to parse message data
Fri Feb 23 19:26:54 2024 daemon.warn odhcpd[1477]: No default route present, overriding ra_lifetime!
Fri Feb 23 19:26:54 2024 daemon.notice netifd: lte (17468): PIN verification is disabled
Fri Feb 23 19:26:55 2024 daemon.notice netifd: lte (17468): Device does not support 802.3 mode. Informing driver of raw-ip only for wwan0 ..
Fri Feb 23 19:26:56 2024 daemon.notice netifd: lte (17468): Waiting for network registration
Fri Feb 23 19:26:57 2024 daemon.notice netifd: lte (17468): Starting network lte
Fri Feb 23 19:26:57 2024 daemon.notice netifd: lte (17468): Unable to connect IPv6
Fri Feb 23 19:26:57 2024 daemon.notice netifd: lte (17599): Stopping network lte
Fri Feb 23 19:26:57 2024 daemon.notice netifd: lte (17599): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "lte" } (Permission denied)
Fri Feb 23 19:26:57 2024 daemon.notice netifd: Interface 'lte' is now down
Fri Feb 23 19:26:57 2024 daemon.notice netifd: Interface 'lte' is setting up now

Unfortunately the same result with a slightly different message...

Query the modem with AT+CGDCONT? and show the result.

Hi AndrewZ

can you please give me a hint how to query the modem? What do I need, perhaps you can provide me a link? I am relatively new to OpenWRT, despite from my Linksys WRT54 Router 2004

Thanks and best regards
Jens

If you followed OpenWrt instructions regarding QMI https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle then you should have noticed this: Please read about AT commands for your modem.
Use picocom as shown there, but with /dev/ttyUSB1.

I tried "picocom /dev/ttyUSB1" and then "AT+CGDCONT" ... the response was "OK"

And yes I also followed the linked HowTo about using the QMI LTE modems. All mandatory packages were already installed... I also tried some hints like installing the optional, but I was not sure if that really was necessary...

Thank you very much for your help :slight_smile:

Command is incomplete.

Ups...

AT+CGDCONT?
+CGDCONT: 1,"IP","internet.t-mobile","0.0.0.0",0,0,0,0
+CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 3,"IPV4V6","hos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
+CGDCONT: 4,"IPV4V6","sos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1

OK

Great, now: AT+CGDCONT=1,"IPV6","internet.v6.telekom"
then reboot and re-check the System Log.

I am not sure, but it looks like I am connected now... need to check it when I'm @ home again... and unplug the Ethernet cable :wink:

The lie state looks like it has already transferred data:

Protocol: QMI Cellular
Uptime: 0h 10m 1s
RX: 302.75 KB (519 Pkts.)
TX: 107.95 KB (486 Pkts.)
IPv6: ****:****:****:****:****:****:****:****/128
IPv6-PD: ****:****:****:****::/64

I think I will check tomorrow morning.

Many, many thanks in advance... but what was it I made wrong?
Best regards
Jens

Glad we have some progress.
Add to the lte interface:

option peerdns '0'
list dns '2001:4860:4860::64'
list dns '2001:4860:4860::6464'

Install 464xlat package and add a new interface:

config interface 'clat'
        option proto '464xlat'

Hi @AndrewZ

many, many thanks for your help, it actually works with my SIM card. So... I have set the google dns server, installed the "464xlat" package and setup the "clat" device.

Just to clarify for myself, my SIM card does only support IPv6, so I will use the google IPv6 dns server and need a IPv4/IPv6 translation service for "non-IPv6" devices in the network behind the router? Telekom states the APN supports IPv4 and IPv6, but now it is fixed to IPv6... may this lead to issues?

I also have a little off-topic question... I want to take this router on vacation in summer and perhaps buy a prepaid sim for data in some eu countries... may I encounter issues with these sim cards and configs also? Is there a website showing the APNs and also the changed config?

No, the limitation sits somewhere else, SIM is just a piece of plastic used to store data.

You need any DNS64 capable server in order to use NAT64 service offered by your provider. That is needed to access "non-IPv6" hostnames on the Internet. 464xlat works in conjunction with NAT64 as well, it comes into play when you need to access IPv4 literals (IP addresses without using hostnames). With both pieces in place you should be able to access everything.

You never know. Some carriers will work with any APN, others will expect you to use the proper one. If this information is not provided along with the SIM card you will need to search, but this kind of information is widely available. You may have to adjust the APN name and IP type on both the router and the modem.

Cool, thanks for your explanation :slight_smile: and with the AT-command I sets IPv6 and the telekom APN on the Modem :star_struck:

So I can use these commands with other cards, when they make problems :wink:

Thank you very much!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.