[SOLVED] Xiaomi R3P OpenWrt boot fails

Hi! I have installed OpenWrt to my Xiaomi R3P. My OpenWrt fails to boot after I edited /etc/rc.local content. After power plugged red light blinks 2.5 times per second for 30 < seconds and red light turn on(stop blinking) for 4~5 seconds and start to blink again. Is there any way to fix this problem?

Boot in failsafe mode and remove the script from rc.local for a start.
Then make sure the script exits normally, before re-adding it as a boot script.

1 Like

How can I go into failsafe mode? I saw article from openwrt homepage and after saw packet says press the reset button but it doesn't boot as failsafe mode. There are no button without reset button in my router. Do I need uart kit to do that?

I think I succefully triggered failsafe mode.
My router's LED blinks really fast. The guide says like below.

A faster, 10-per-second blink if the user pressed a button and failsafe mode was triggered

I saw that in failsafe mode router boots to but I can't ping or ssh to timed out.).

I solved it. The reset button were that "button" to push and I succefully triggered failsafe mode. To ssh openwrt( the lan cable has to be connected to wan port. Thanks for your support @trendy

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.