[SOLVED] Xiaomi AIoT AX3600 installation issue

Greetings, I am getting into a loop hole. After my AX3600 bricked during the first flashing attempt I recovered it. I am now in a dead end ubiformat is reporting to me that the requested ubi file does not exist which I confirmed is the opposite.

What did I do?

ssh root@192.168.31.1
cat /proc/mtd
mtd0: 00100000 00020000 "0:SBL1"
mtd1: 00100000 00020000 "0:MIBIB"
mtd2: 00300000 00020000 "0:QSEE"
mtd3: 00080000 00020000 "0:DEVCFG"
mtd4: 00080000 00020000 "0:RPM"
mtd5: 00080000 00020000 "0:CDT"
mtd6: 00080000 00020000 "0:APPSBLENV"
mtd7: 00100000 00020000 "0:APPSBL"
mtd8: 00080000 00020000 "0:ART"
mtd9: 00080000 00020000 "bdata"
mtd10: 00080000 00020000 "crash"
mtd11: 00080000 00020000 "crash_syslog"
mtd12: 023c0000 00020000 "rootfs"
mtd13: 023c0000 00020000 "rootfs_1"
mtd14: 01ec0000 00020000 "overlay"
mtd15: 00080000 00020000 "rsvd0"
mtd16: 0041e000 0001f000 "kernel"
mtd17: 015cc000 0001f000 "ubi_rootfs"
mtd18: 01876000 0001f000 "data"

then


scp openwrt-23.05.3-ipq807x-generic-xiaomi_ax3600-initramfs-factory root@192.168.31.1:/tmp                 100%   13MB   7.4MB/s   00:01
cd /tmp
ls
cd /

confiremd that openwrt-23.05.3-ipq807x-generic-xiaomi_ax3600-initramfs-factory is indeed in the /tmp folder.

to be extra secure I did run the command nvram get flag_boot_rootfs and it returned 1
Here comes my issue where I am scratching my head.

root@XiaoQiang:~# ubiformat /dev/mtd12 -f /tmp/openwrt-qualcommax-ipq807x-xiaomi_ax3600-initramfs-factory.ubi -s 2048 -O
 2048 && nvram set flag_boot_rootfs=0 && nvram set flag_last_success=0 && nvram commit
ubiformat: mtd12 (nand), size 37486592 bytes (35.7 MiB), 286 eraseblocks of 131072 bytes (128.0 KiB), min. I/O size 2048 bytes
libscan: scanning eraseblock 285 -- 100 % complete
ubiformat: 216 eraseblocks have valid erase counter, mean value is 0
ubiformat: 70 eraseblocks are supposedly empty
ubiformat: warning!: only 216 of 286 eraseblocks have valid erase counter
ubiformat: mean erase counter 0 will be used for the rest of eraseblock
ubiformat: continue? (y/N) y
ubiformat: use erase counter 0 for all eraseblocks
ubiformat: error!: cannot open "/tmp/openwrt-qualcommax-ipq807x-xiaomi_ax3600-initramfs-factory.ubi"
           error 2 (No such file or directory)

I tried to look into the issue but seems there is no clear answer on how to fix that only thing I did not try was using a live linux distro.

That's the filename. And this is what you're telling ubiformat to install:

Notice a difference? :slight_smile:

The wiki page also says the following:

Take into account that the name of the files can be different depending of the version you want to install, so replace accordingly

I would suggest just using autocomplete (Tab) to get the filename right. :slight_smile:

My god, never do projects at 10PM....

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.