[SOLVED] Xiaomi 3g and OpenVPN/kmod-tun problem, bad kernel version

Can I please ask for help. I have a problem with installing packages needed for OpenWRT.
I currently use Release build for Xiaomi3g 18.06.1 (4.14.44). Upgraded from stapshot with sysupgrade
And here the problem:
opkg install kmod-tun tries to install module for 4.14.68 kernel.

# opkg files kmod-tun
Package kmod-tun [(4.14.68-1](tel:414681)) is installed on root and has the following files:
# uname -a
Linux router 4.14.44 #0 SMP Fri Jun 1 19:01:[03 2018](tel:032018) mips GNU/Lin

Thanks a lot!

  • Can you describe your problem in more detail?

It appears your package is actually installed...does it work?

Also be advised, that packages update in the repisitory.

Well insmod /lib/modules/4.14.68/tun.ko made it work... I install kmod-tun by forcing opkg deps.
But I'm curious is it normal that OpenWRT 18.06.1 kernel version on my device is 4.14.44 and tun module is build for 4.14.68. Is it ok, or something goes wrong while updating to 18.06.1
Sorry for my naive question, just another newbie here :slight_smile:

I did think something was wrong...

Did you upgrade to another snapshot?

I grabbed update from here https://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7621/openwrt-18.06.1-ramips-mt7621-mir3g-squashfs-sysupgrade.tar .
Router was updated using webUi.
Maybe installer updates wrong kernel (from what I understand there is 2 kernels)
Reinstalling with sysupgrade gives me the same result.

Solved by brute force (mtd):

cd /tmp
wget https://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7621/openwrt-18.06.1-ramips-mt7621-mir3g-squashfs-kernel1.bin
wget http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7621/openwrt-18.06.1-ramips-mt7621-mir3g-squashfs-rootfs0.bin
mtd write openwrt-18.06.1-ramips-mt7621-mir3g-squashfs-kernel1.bin kernel
mtd write openwrt-18.06.1-ramips-mt7621-mir3g-squashfs-rootfs0.bin ubi

and voila ...

# uname -a
Linux noxter 4.14.63 #0 SMP Thu Aug 16 07:51:15 2018 mips GNU/Linu

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.