[solved] X86 and x86_64 generic doesn't start headless

Hi, i hope someone can help me. I just installed the last x86/generic combined-ext4 17.01.02 image on an older Intel N270 device with 2 Realtek NICS.

The problem: It will not start until i press Enter with a keyboard inside Grub2. Seem a complete nonsense for a router. The rest is running just fine.

EDIT 1: I cant see any grub config files.


did you tried without keyboard attached ?
maybe it is broken

I did, no change. With a screen, i cant see any countdown happening (like the 4 sec. mentioned in the wiki). I have to choose between normal boot and failsafe.

EDIT1: Any other OS start normaly, so i dont think its an hardware issue.

did you tried using a snapshot ?
I think it has grub updated

I will give it immediatly a try with a fresh install.

EDIT: Newer Grub2 version, but still the same problem.
EDIT 2: I will give soon a try with the grub command line. But since i dont know where the config files are placed...

Im bumping this since i really want to use LEDE on this device. Thanks in advance.

what happens after the countdown?

does any sort of linux boot automatically on the system ?
did you try to make a manual compile and set grub timeout to 0 ?

No Countdown is hapenning. Thats the problem. I need to press Enter.

Any other Linux boot without issues. Until now i didnt compiled an image myself.

I am going to test this tonight. I'm just installed x86_64 version last night and was noticing it requires me to choose between lede and lede failsafe. It was very late to I didn't worry too much about it at the time. I don't reboot often but it would be ridiculous to me to have to enter a keystroke to boot the system on a router. EDIT: 17.01.02

1 Like

Have you tried the ROOter build of LEDE? I'm running it in a VirtualBox VM. I have no issues during boot with the countdown, etc. No input on the console required. I did have an issue with having to fix a corrupt file system in the virtual disk image (vdi), but I was able to address that attaching it to a GParted Live VM. Anyway it's available here if you want to try a different tactic -- ROOter is generally more ready-to-deploy and has great support for USB cellular modems:


1 Like

Good to know. I think somebody (or myself heh) need to report that "bug". The problem i see are in case of power outage, and if an hard reset is needed after a freeze.

Thank you, i will give it a shot after breakfast.

EDIT: even with this image, i need a keystroke.

It has always "just worked" for me booting various old desktops directly from cold (i.e. no VM) from a USB flash drive.

Do you have a /boot/grub/grub.cfg file? This is the standard one:

serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1 --rtscts=off
terminal_input console serial; terminal_output console serial

set default="0"
set timeout="2"
set root='(hd0,msdos1)'

menuentry "LEDE" {
	linux /boot/vmlinuz root=PARTUUID=0d946b2e-02 rootfstype=ext4 rootwait console=tty0 console=ttyS0,115200n8 noinitrd
menuentry "LEDE (failsafe)" {
	linux /boot/vmlinuz failsafe=true root=PARTUUID=0d946b2e-02 rootfstype=ext4 rootwait console=tty0 console=ttyS0,115200n8 noinitrd

The "default" and "timeout" lines should cause an auto boot. The serial port setup may be hanging if your system has no serial hardware, so in that case remove that line.


Since your intention is to be headless, and so "LEDE (failsafe)" is irrelevant, couldn't the grub file just contain:

linux /boot/vmlinuz root=PARTUUID=0d946b2e-02 rootfstype=ext4 rootwait console=tty0 console=ttyS0,115200n8 noinitrd

And, as more of a question, if there is no console could the output just be sent to null?

Thank you, it works!

tty0 will print to the video hardware through the BIOS. ttyS0 is a serial port. Any modern x86 should have some sort of video output; it can be helpful for debugging to plug in a screen. If you install kmod-usb-hid (and dependencies) you can use a USB keyboard along with the screen as a text terminal.