[SOLVED] 'wwan' proto doesn't work

I am doing some useful fixes for NCM protocol.

It is better to fix it together with wwan proto. I found some bugs in
/lib/netifd/proto/wwan.sh and have some improvements to suggest.

But the problem is that in 18.06 branch wwan proto doesn't work at all. I have no idea how debug it. Probably something in netifd is broken.

If I set option proto 'wwan' the system does nothing. wwan.sh never starts.

I am using Huawei E3276 model. It works well with NCM. I tried to switch it to RAS mode, but no dice.

Is there anyone who has some knowledge about it?

I found the problem. I built a system without ppp, and the script includes ppp.
There is no error. It silently doesn't start.
I commented out some includes and it works.

But the wwan and ncm is a real pain for different devices with different configurations and modifications.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.