[Solved] WRT32x no internet connection

Hi! I’m not a power user and just a beginner. I have flashed my WRT32x with OpenWRT and used SSH to connect to it. I cannot install LUCI however as there is no internet connection. I have put my modem in bridge mode but no change. How to proceed? When I set up the router with stock firmware, I needed the PPPoE account details before acquiring internet access, could this be the problem?

WRT32X is supported by 19.07.4 which includes Luci web administration.

Sounds very possible. The default wan protocol is dhcp client, which won't work if you need to connect by pppoe to your ISP.

1 Like

have you tried to open the openwrt web admin using your desktop browser?

Ah great thanks, so I just have to change WAN settings to PPPoE? Could you tell me how to do this? I’ve done a search but am not much the wiser.

@asdffdsa Yes nothing opens. There is no LUCI, I thought I needed to install it.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; netstat -lnp | grep 80

using ssh, with a client to server port forwarding rule.
that is how i connect

@trendy I am sorry I cannot copy and paste between my iPhone and the laptop connected to the router. The laptop connected to the router has no internet.

Gather the output of these commands on your laptop, then enable hotspot on the iphone and post them here.

@trendy the laptop is very old and will not acquire my iPhones hotspot. It is the only laptop I own with a RJ45 Ethernet port.

run a ssh client on the iphone....

1 Like

run a port scanner on the router, see what ports are open.

Do you know at least which version of OpenWrt have you installed?

@trendy I could pause this, reset to stock firmware, order an Ethernet to usb-c adaptor, and try again on my MacBook Pro.

@trendy 19.07.4 (V1 Venom listed on device page)

This one has luci.
Run this command and verify that there is something similar to you too:

root@magiatiko:[/]#netstat  -lnp | grep http
tcp        0      0    *               LISTEN      2608/uhttpd
tcp        0      0   *               LISTEN      2608/uhttpd
tcp        0      0 :::80                   :::*                    LISTEN      2608/uhttpd
tcp        0      0 :::443                  :::*                    LISTEN      2608/uhttpd

Clear browser cache and try entering the default IP to access the web interface.

@trendy I’m in! Should have cleared cache first thing! Thanks!


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

@trendy One more thing, once in web interface, how to configure it to PPPoE?

@trendy Changing the WAN and WAN6 to PPPoE does not seem to have resolved it.