[Solved] Wrt32x as acces-point - switch configuration

Hello,

i have change my Wrt32x as acces-point device (and nas - ftp server - rclone...)
it works but i'm not totally sure of the switch configuration

Can someone comfirm or correct this configuration ?

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbf:7a89:0f78::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ifname 'eth0.1 eth1'
        option gateway '192.168.1.254'
        option dns '192.168.1.254'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '100'
	option ports '4t 6t'

thanks

ls -l /sys/class/net
swconfig list
swconfig dev switch0 show

https://openwrt.org/docs/guide-user/network/vlan/switch
https://openwrt.org/docs/guide-user/network/vlan/switch_configuration

Right vlan 100.........

Thanks !

change like this

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbf:7a89:0f78::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option gateway '192.168.1.254'
	option dns '192.168.1.254'
	option ifname 'eth0.1 eth1.1'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 4 5t'

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.