[SOLVED] WRT3200ACM WiFi breaks after ~5 hours due to radio2 enabled

By default, OpenWrt flash configures 3 radio signals that are disabled. After renaming and enabling them I noticed on the Overview page that the memory gets full, which later led me to notice that after a few hours the WiFi signal drops. I then have to reboot the router every time after about 3-5 hours every time.

This is the current release information I am using for my setup.

630 Linksys WRT3200ACM v1 (rango) 18.06.0 Marvell Armada 385 88F6820 mvebu cortexa9

Please help me with this issue or point me in the right direction.

Sounds like a memory leak somewhere and OOM killer kicking in. It would help if you could check top output right after a reboot and at the point when you see your RAM filling up - and compare memory usage. You can sort top output I think, but you might feel more comfortable with something like htop, which has a more intuitive interface.

1 Like

With the current state of radio support, enabling the radio2 is not advisable. I don't enable radio2 on my WRT3200ACM and it's running for months between reflashes (I do use @eduperez'es updated wireless driver/firmware tho).

1 Like

Works fine on my end, I'm only using 5Ghz however.
The SDIO radio seems a bit dodgy, at least the bluetooth part.

Running trunk/master with a few modifications which shouldn't affect stability however.

1 Like

Yeah I don't use radio 2 and don't have any probs. Radio 2 is low power I think anyway.

1 Like

For whatever reason, my radio2 reports all the power and radio0 and radio1 do not transmit a signal. In fact I tried to disable radio2 and it reverted the changes.

i currently tried to install @eduperez driver set but the wget command to download the files is not working for me.

"Is not working for me" is not very informative... if you expect to receive any help, I think you should be more explicit.

1 Like

I understand. Thanks for your help. With reading through the forums I resolved my own issue with previously mentioned solutions.

Would you be willing to reply to this thread with your solution, so others may see how to fix it - should they too search the forums for an answer?

Also consider editing the title and appending "[SOLVED]" to the beginning.

1 Like

After a fresh reset of my version of OpenWRT I left radio2 disabled as advised which ultimately fixed the issue of the wifi kicking off after about 5 hours. Installing other drivers may be an option, but it is important to note that you attempt at your own risk.

I took the following steps on OpenWRT version 18.06.0 and installed @eduperez drivers found here using the following instructions:

STEP 1: Connect to router via Terminal
ssh into router and enter the following commands

STEP 2: Install wget and needed wget dependencies using this command
opkg update && opkg install libustream-openssl ca-bundle ca-certificates wget

STEP 3: Download the mwlwifi commit 7537480 for OpenWrt 18.06.0 using this command
wget https://github.com/eduperez/mwlwifi_LEDE/releases/download/7537480/mwlwifi-firmware-88w8964_10.3.8.0-20180810-75374802-1_arm_cortex-a9_vfpv3.ipk && wget https://github.com/eduperez/mwlwifi_LEDE/releases/download/7537480/kmod-mwlwifi_4.14.54+

STEP 4: Install the drivers with this command
opkg install --force-downgrade kmod-mwlwifi_4.14.54+ && opkg install --force-downgrade mwlwifi-firmware-88w8964_10.3.8.0-20180810-75374802-1_arm_cortex-a9_vfpv3.ipk

STEP 5: Reboot for settings to take effect
reboot now

Thank you @stangri @diizzy @tapper for the suggestions and thank you so much @eduperez for the development efforts. :grin:


Afaik just wifi also works, no need to reboot.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.