[Solved] WRT3200ACM - Unable to flash LEDE successfully

ok i found the patch that is wrong.
it is an older build for this staging for kaloz:
https://git.openwrt.org/?p=openwrt/staging/kaloz.git;a=blob_plain;f=package/kernel/mwlwifi/Makefile;hb=HEAD

there will be a new build, in about 15 hours. the wifi will be right, just i was using a newer Makefile and the kaloz staging was older, so i kept the 2018-01-18 dated mwlwifi. that was why the firmware wifi was missing.

Ok, hopefully, now it is good (i fixed the mwlwifi):
https://cdn.corifeus.com/openwrt/SNAPSHOT/targets/mvebu/generic/

https://cdn.corifeus.com/openwrt/SNAPSHOT/targets/mvebu/generic/insomnia-latest-mwlwifi-openwrt-snapshot-insomnia-mvebu-linksys-wrt3200acm-squashfs-factory.img

Ok, it is verified:

Hello,

It seems to work now !
Installed:
https://cdn.corifeus.com/openwrt/SNAPSHOT/targets/mvebu/generic/insomnia-latest-mwlwifi-openwrt-snapshot-insomnia-mvebu-linksys-wrt3200acm-squashfs-factory.img

Have not tested so much yet.
Uptime only 38 min.

5.0 GHz WiFi radio0 works!
2.4 GHz WiFi radio1 works!
WiFi radio2 is not tested, but I can see this in Luci GUI.

Very well done! !!!!

Regards
Per-Ove

@patrikx3
Please let me know if the Scan button works for each radio?

  • you should see some access points
  • signal strength should not be 100% (I have this problem with radio0 and radio1).

I do not have a Winbond. I just built it, I cannot test it.
But some guys work'it.

Besides there is a 3rd one as well, I use it for guest.
But works with Winbond as well.
image

This is important for mwlwifi:
image

And this:
image

On my device

  • all scan buttons work.
  • radio0 and radio1 show 100% signal strength for every network, radio3 does not

it's your own built?

@patrikx3 No, this one:

@MacKlappstuhl
Thank you for confirming! Any ideas how to solve this?

Scanning from the command line returns the same results.

  • iwlist scan wlan0

  • iwlist scan wlan1
    both return 100% e.g. Quality=70/70 Signal level=0 dBm

  • iwlist scan mwlan0
    returns proper values e.g. Quality=47/70 Signal level=-63 dBm

but does show the radio3? or not?
if it shows, i could only make it work with exact same settings radio1 = radio3 (5ghz)
look at the pictures above, i had to use the same exect as the picture shows.
does it show in LUCI in wireless interfaces?
or not?
if it is missing, you might have kept a setting that was missing the wifi.

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
	option txpower '20'
	option country 'FR'
	option htmode 'VHT80'
	option channel '44'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'patrikx3-digi'
	option encryption 'psk2+ccmp'
	option key '1234567890'
	option wps_pushbutton '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
	option txpower '20'
	option country '00'
	option htmode 'HT20'
	option channel '4'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'patrikx3-digi-slow'
	option key '1234567890'
	option encryption 'psk2+ccmp'
	option wps_pushbutton '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode 'VHT80'
	option country '00'
	option channel '44'
	option txpower '21'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option wps_pushbutton '0'
	option ssid 'patrikx3-digi-guest'
	option key '1234567890'

I can only use no auto-bw, dfs channels, just the once that cannot be use the radar and 80 Mhz only.

root@digi:~# iw reg get
global
country 98: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
	(5490 - 5710 @ 160), (N/A, 23), (0 ms), DFS
	(57240 - 63720 @ 2160), (N/A, 40), (N/A)

phy#2
country US: DFS-FCC
	(2402 - 2472 @ 40), (N/A, 30), (N/A)
	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
	(5735 - 5835 @ 80), (N/A, 30), (N/A)
	(57240 - 63720 @ 2160), (N/A, 40), (N/A)

phy#1
country FR: DFS-ETSI
	(2402 - 2482 @ 40), (N/A, 20), (N/A)
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
	(5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country FR: DFS-ETSI
	(2402 - 2482 @ 40), (N/A, 20), (N/A)
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
	(5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

That's a small description.
So either you remove the radio3 and totally remove as mwlwifi says, where is says
https://github.com/kaloz/mwlwifi#special-considerations at the Note for DFS of WRT3200ACM, then you can use all channels and use the radar as well, or you keep 3 radios and only 80 Mhz

Very complex to set it up.
Besides the picture help a bit as well.

If I install the bare bone, I cannot install luck after that: I get a message that Lucia is not available. Neither is Adblock, etc. Is that expected? I did run opkg update first

root@OpenWrt:~# opkg install luci
Unknown package 'luci'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci.
root@OpenWrt:~# opkg install luci-ssl-openssl
Unknown package 'luci-ssl-openssl'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci-ssl-openssl.

@fantom-x

Well, given it is a custom build and doesn't change, because every new update changes the kernel etc (the OpenWrt master), the only options is to add in the opkg keys as here (just click this link, it will explain what you to do):
https://github.com/patrikx3/openwrt-insomnia#if-you-just-use-one-or-a-few-feeds-non-insomnia-firmware-your-router-needs-a-signature (by package signature verification)

Although the fast is this:
https://github.com/patrikx3/openwrt-insomnia#option-3-manual-with-ssh (but then if will skip the package signature verification, though I haven't added any worm, so don't afraid, of course... :slight_smile: )

(the bare build doesn't allow to inject opkg keys, only the image builder with the ones which starts with insomnia, the keys are in-built, but of course I added a tons of packages into the ROM :slight_smile: )

So, then, after any option you choose, before you want to install, update the packages first:

opkg update

Then you can install everything you want, but given the packages are from the latest OpenWrt on March 23. 2018. and kaloz's staging OpenWrt repo I built on, it is possible some packages will not work, but it is not possible to do it any other way. Maybe I could build all the packages on that daty were commited like February, if it is that bad, I could build by that commit on kaloz's staging OpenWrt repo. Though some guys using the insomnia firmware, but given nothing is stable, error could happen (unlike LEDE, because I only use 17.01.4 - I don't have Winbond, I can test it or help you at all, if it works, awesome, if not, sad)....

The verbose information about signatures and how the packages are verified, here:
https://github.com/patrikx3/openwrt-insomnia#signatures (about how the signatures, I sent e-mail them, to add it into Lede/OpenWrt but I received no response, so right now my key is not in official Lede or OpenWrt, just my own http://cdn.corifeus.com), given it is working now, I am not building a new kernel/packages every day, unlike http://downloads.lede-project.org/snapshots/targets/mvebu/cortexa9/ ....

You will not have any other option right, I think the OpenWrt is missing the Winbond and even once it will be integrated, it changes every day, the SNAPSHOT-s, meaning the packages/kernel changes every days, so it is completely usable (as I understand, given you try a new updated package, but the kernel is changed, you have to reinstall the firmware again etc..), so much for now, until a tag version or new STABLE OpenWrt is released.

For Lede (missing Winbond), you can just change the opkg sources and you can install from there, but given totally custom build, this is you have to do.
Besides you wouldn't need my firmware at all....

Sincerely,
Patrik

Oh, I missed that. I tried flashing the stable v17, and it eventually rebooted into the stock firmware. So, I guess that proves I have this new HW modification of art32000acm. Are these changes in master or your build is my only option for now?

It is in only Kaloz's staing repo in OpenWrt (it is not merged since February), you can build on the same settings I built, it is all in a Dockerfile in Gihub like this:

1 Like

I have not found other firmware that supports, so I just helped and created this build, but of course it is my own automatic build and it includes tons of packages form openvpn, samba, nano, etc, it is in my readme.md.

Besides it includes all packages you need to setup an ext-root so you can not use the ROM (which is like an SSD, sometimes it will be be worn out), you can read about ext-root (some info you can exclude) here:
https://github.com/patrikx3/openwrt-insomnia/blob/master/docs/ext-root.md (this is my setup, USB3 500-1000 GB I use), you can use it up to THIS IS MY OWN SETUP. In insomnia though you don't even need to install anything, they are in the insomnia firmware .... etc ... etc ...

1 Like

Hmm, Is it really just a two line change in a dts file? If that is the case, I can simply build my own image from either master or the stable branch. Am I wrong?

Yes, just two lines in DTS edited directly wih kernel 4.4 and 4.9, and patched for kernel 4.14 as there the DTS originals are already in the main kernel sources.

https://git.openwrt.org/?p=openwrt/staging/kaloz.git;a=commitdiff;h=7ae59a2f288ba1cef23b20e1d36e199e8c646245

And yes, just by applying that one commit from Kaloz to your local source repo, you can build directly from master or 17.01. There is no need to build the whole firmware from the Kaloz staging repo.

(I have built my own CPU frequency scaling test build with Kaloz patch for master with 4.14 and it doesn't seem to cause anything special for an older non-affected WRT3200ACM.)

radio3 is not shown in LUCI, only radio0-2. I can not find any indication for a fourth wifi device in /etc/config/wireless or via ip a.

Thanks for all the information, I will look into it in the next week.