[Solved] WRT3200ACM - Unable to flash LEDE successfully

It appears that Belkin has changed things up on recent rango units:

  • two individuals with same device
  • same DoM on units
  • same noted difference from previous units
  • same issue experienced
  • note on OEM site regarding recent FW and reset required

My eyesight may be dimming, but to me it appears something is going to have to change in image generation, once it ascertained as to all changes; and it sure looks like at a minimum there is a DTS change required.

@MacKlappstuhl As I have not been able to brick any of the wrtpac members that I have owned, no matter how hard I have tried, so I have not had to fight that fire. But, as noted above, I would suggest whatever it is you do, be sure to take any replacement partition data from a similar unit, not an earlier DoM unit; we just don't know what the changes are at this point.

And for those wanting/needing traction on this issue, not much is going to happen without at least an open FS, with some pertinent information.

Linksys has pulled that firmware version and reverted back to 1.0.6.181063 and Linksys is also giving downgrade instructions at their page: https://www.linksys.com/us/support-article?articleNum=207552
Apparently there were problems with that version 1.0.6.184351.

https://community.linksys.com/t5/Wireless-Routers/WRT3200ACM-1-0-6-184351-Firmware-and-Wireless-Lockups-5ghz-radio/td-p/1237411/page/26

And you are not the only one who can't downgrade: https://community.linksys.com/t5/Wireless-Routers/WRT3200ACM-1-0-6-184351-Firmware-and-Wireless-Lockups-5ghz-radio/td-p/1237411

But if that version works for you (and you seem unable to downgrade), you might stick into that, until Linksys comes up with the next version. Might be more sure than trying to forcefully downgrade with a serial flash.

Not 100% sure, but based on posts from mwlwifi issue 243 it looks like the downgrade was due to issues with the wifi BLOB.

I hope that this can be of use here. If not please remove this post (it is my first one in here). I have two WRT3200ACM routers and I'm almost ready to convert one of those to the bright side of the firmware; maybe, at a later date, the other one will be "reformed" to LEDE too. As a first step, just to be sure the the units had no factory issues, I tried a few times to install, upgrade and downgrade both the routers with images from Linksys; doing that I was stuck with version 1.0.6.184351 regardless if I tried to downgrade to version 1.0.6.181063 or not. I didn't do a thoughtful research but I was able to find another Linksys image available only on the U.S. Linksys support site, named version 1.0.6.186168 and that image is now installed in both my routers. Maybe you can try to do the same. The new image is available at this link: http://downloads.linksys.com/downloads/firmware/FW_WRT3200ACM_1.0.6.186168_prod.img
At the moment the U.S. Linksys support site is the only one linking the new image (Yes, I checked all the other countries). Please note that maybe the image 1.0.6.186168 might not be certified by LInksys for your country (or Linksys is just too slow in updating all the websites at the same time... translators are having a break?).
Now even if the support page for my country (Italy) gives instruction about a downgrade from 1.0.6.181063 to 1.0.6.184351, the latter is no longer available.
The changelog for the new 1.0.6.186168 image http://downloads.linksys.com/downloads/releasenotes/WRT3200ACM_Customer_Release_Notes_1.0.6.186168.txt reports:

Product: Linksys WRT3200ACM
Classification: Firmware Release Notes


IMPORTANT:

  • DO NOT power cycle the Router during the firmware upgrade process.

===========================================================================

Firmware version: 1.0.6.186168
Release date: January 16, 2018

  • Integrated WLAN FW v9.3.2.3
  • Resolved Wi-Fi connectivity issues triggered by Android clients

Firmware version: 1.0.6.184351
Release date: October 27, 2017

  • Integrated WLAN driver v9.1.1.4 and FW v9.3.1.2
  • Added support for Winbond and MXIC flash
  • Fixed VPN access over PPTP
  • General bug fixes

Firmware version: 1.0.6.181063
Release date: May 18, 2017

  • Incorporates compliance with CE Radio Equipment Directive 2014/53/EU
  • Addressed IOActive security issues
  • Added support for IPv6 frames using ESP (XBox One)
  • Added IPv6 support for British Telecom (BT)
  • General bug fixes

Firmware version: 1.0.5.179030
Release date: April 5, 2017

  • Integrates WLAN driver v9.0.9.0p3 and FW v9.2.1.5
  • Integrates multiple bug fixes

Firmware version: 1.0.5.176416
Release date: October 25, 2016

  • Integrates WLAN FW v9.2.1.3
  • Resolves a connectivity issue with the Blossom Smart Watering Controller
  • Resolves a MU-MIMO communication issue with the XiaoMi Mi4i
  • Improves wireless throughput at longer distances

Firmware version: 1.0.5.175944
Release date: October 6, 2016

  • Integrates WLAN driver v9.0.9.0 and FW v9.2.0.8
  • Resolves a guest network connectivity issue
  • Improves the MU-MIMO client grouping algorithm

Firmware version: 1.0.4.175663
Release date: September 23, 2016

  • Integrates WLAN driver v9.0.8.5 and FW v9.2.0.4
  • Fixes bug triggered by sysinfo page access
  • Improves TCP throughput for Macbook wireless clients

Firmware version: 1.0.3.175384
Release date: September 6, 2016

  • Initial release
2 Likes

@giovanni You, Sir, are awesome. I would have never came up with the idea to look at different countries support sites for updated firmware versions.

Here is what I did:

  1. Downloaded the image linked in @giovanni ´s post
  2. Established serial connection to the router
  3. Issued the following commands:
  • setenv ipaddr 192.168.1.1
  • setenv netmask 255.255.255.0
  • setenv serverip 192.168.1.254
  • run update_both_images
  • reset

The image flashed successfully, the router rebooted. Putty showed what I think is a normal Linksys boot log.

The weird thing is that the WebGUI was not reachable via standard IP (192.168.1.1) and there was no ping result. Wifi was working, and I was able to connect to it with the password given in in the quick start guide. The router had a quite strange IP (10.30.52.149), but I got a ping result from that and was able to enter the WebGUI. The default password (admin) did not work though.

After trying a few common passwords I pressed the reset button for 10 seconds. The router booted with its default IP (192.168.1.1) and I was able to enter the WebGUI with the default password (admin).

The router should now be in a "factory-new" state. Booting it via run nandboot and run altnandboot is working so both images should be fine, right?

Is there anything I can do to confirm or disprove that there was an unannounced hardware change?

1 Like

Check the kernel log for the ID of the flash chip.
Likely you have the new Winbond chip.

I linked you yesterday the new discussion that suggests that there are now Winbond flash chips used in WRT3200ACM. (The release notes above are the same that I quoted in [Solved] WRT3200ACM wont accept firmware

There has likely been a flash chip change, and the new routers with the new chip do not yet work with Openwrt/LEDE or with older Linksys firmwares, but need Linksys 1.0.6.184351 or 1.0.6.186168

1 Like

It should resemble the Armada 385 boot log in the wiki.

This should be it:

[ 1.978069] NAND device: Manufacturer ID: 0xef, Chip ID: 0xda (Unknown NAND 256MiB 3,3V 8-bit), 256MiB, page size: 2048, OOB size: 64

Full paste here. (Line above is line 262 in pastebin)

@JW0914 It does, more or less. Thanks for the hint.

Interesting that they have not bothered to add the manufacturer to the vendor database.

We should probably look at the GPL sources and see how they patch mtd.

Do you know if it's possible for you to backup your bootloader and send me it?

I flashed the older style v0.0.4 and my device is currently bricked.

There is currently no uboot image that I can find that works with kwboot for my device as there all v0.0.4.
I noticed you have v1.0.0 which is the one I need :confused:

Thanks

@GaZaai That's also in the wiki, thanks to nitroshift and Stefan Roese

That's what I am trying to say though that must be for the older board. I have the new Winbond and the one in the Wiki just get stuck in a loop and doesn't boot. I need the newer version

Ah, I misunderstood.

I'd also open an issue on nitroshift's GitHub to let him know.

  • If you already know how to compile, you should be able to compile the bins required, as I believe the source files are available from U-boot
    • I could be wrong, but I thought I came across someone mentioning that when I was trying to figure out how to compile an mmc boot file for my ClearFog Pro

I will do my best to assist you. Lets talk via PM.

1 Like

I would love to be able to do that JW0914 :grinning:

But I'm just not smart enough to understand on how to compile it lol

Big request.

Please, who has the modification of WRT3200ACM with NAND chip Winbond, please make a copy of the boot partition and put the public resource. A copy is needed to restore the router.
You can make a copy with a command from openwrt/lede-
dd if=/dev/mtd0 of=/tmp/mtd0.bin

Thats the problem. AFAIK there is no working OpenWRT/LEDE image available at the moment.

@Valcher
See here: https://github.com/ValCher1961/McDebian_WRT3200ACM/issues/1#issuecomment-359667138

I've not personally tested it yet but I'll have a go once I come back from work tonight.

Edit: Just tested it's just the same 0.0.4 bootlaoder it wont work either. :confused:

It may be faster for someone to simply compile the u-boot spi and uart bins with support for the newer Winbond flash. Uboot will have instructions on how to do so either in their repo README. or in their site docs

  • Needed commands will likely be similar to:
    • export CROSS_COMPILE=<insert-gcc-toolchain>
    • make armada_38x_<insert_boardname>_config
    • make u-boot-a38x-spi-uart.bin
      and possibly
    • make u-boot-a38x-spi.bin
  • Once those are generated, one can simply follow the instructions laid out in Corrupt Bootloader Recovery

I see no one has opened an issue on nitroshift's GitHub, which I would encourage doing since he was the one who worked directly with Stefan Roese of uboot.

  • He also recommended joining #u-boot on freenode servers as a place to also garnish information on what needs to be done

@JW0914

Edit: My post above is just the same image which is available elsewhere. Just tested it and it's version 0.0.4 we need 1.0.0 boot loader. I've also opened an issue with nitroshift now but I don't know if he is still active or not.