[SOLVED] WRT1900ASCv2 no internet over WiFi

Hi

I have installed LEDE 17.02 for Linksys WRT1900ACSv2 and followed the Quick start standard installation (client device).
I was able to successfully connect to the internet while having my computer connected via Ethernet cable to the router.
After having done this I've enabled WiFi, and it appears on other devices and I'm able to connect to the WiFi network.

However here's where it gets strange, I'm unable to access the internet, my computer/phone also notify my there's no internet connection on this WiFi network. Which is strange since wired it does work.

I have no clue what could cause this, and couldn't find an answer (apologies if I overlooked it). I'm new to this, and it's the first time I've installed 3rd party firmware on a router. Hope someone can help.

Here are my configs (should not deviate from defaults too much since I haven't changed much):
root@LEDE:~# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd9f:d2bb:787a::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'
	option dns '192.168.1.1'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'

root@LEDE:~# cat /etc/config/firewall 
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
root@LEDE:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'BE'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'LEDE'
	option macaddr '5a:ef:68:0d:03:31'
	option encryption 'psk2+ccmp'
	option key ‘***’

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option disabled '1'
	option country 'BE'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'LEDE'
	option macaddr '5a:ef:68:0d:03:30'
	option encryption 'psk2+ccmp'
	option key ‘***’

Thanks in advance!

Wrong settings for gateway and dns in LAN interface. You have set them to be the router itself. so there is no route to outside network (or even to a DNS name server)

option gateway '192.168.1.1'
option dns '192.168.1.1'

Both of those lines are normally unnecessary.

I think that you have wrongly used the "client device" advice, although you have a "normal" router device. Please follow the advice "router device" section. (in practice, just delete those two lines above)

Do you have another router (to which the new connects to)?
In that case the "client device" might be ok advice, but then you have ignored part that the device's own IP address can't be 192.168.1.1 (that is supposed to be the address of the next router).

@hnyman thanks for the quick reply! I feel quite silly now, since it was something this simple :sweat_smile:

I do have another router, it's a modem/router all-in-one from my ISP. But I did as you suggested and followed the "router device" setup, and now everything works fine.
The gateway and dns are now blank. What is the reason these are unnecessary? Because the router already knows where to send the packages since it has it's own WAN port?

Thanks

Yes. It has got that info from the modem that acts as the next step for your new device.

You have now "double-NAT" config that is probably not quite optimal performance-wise, but works and is easy to config. (the modem-router already provide a local network and now your new device provides another local network inside that.)

It might be performance-wise better to use just the network from the modem/router and reduce the new router to a dumb wifi AP, and then the "client device" advice would be right (as long as you adjust the new device's IP from be something else than 192.168.1.1).

If you want to test setting the new device as a dumb AP, you could use my own advice for that (a bit simpler than the client device rambling in wiki):

If you connect the two routers using a fixed connection between LAN ports, the whole thing is ridiculously easy, as you can dumb down the APs. (The key to making things really easy is to NOT use the WAN port in the slave APs at all.)

I have written a rather detailed guild about it in Openwrt forum:
(router1 = modem / old router, router2 = new device)
https://forum.openwrt.org/viewtopic.php?pid=340068#p340068
pretty much the same advice as in LEDE wiki but with other words

Hmm :thinking: , I will look into that when I've got the time. With the current setup I get 130-180mbps over WiFi (vs 80-100 with the ISPs router) so it's already an improvement.
Just too bad they only provide modem+router in-one these days :unamused:

Btw, @hnyman wouldn't putting the second (new) router in the DMZ mitigate this overhead? Or would this still leave me with a double-NAT?

Another option would be to check if the ISP device supports bridging/IP pass-through..

Thanks for the tip @anomeome but unfortunately the ISP-device doesn't allow that, they've locked down the thing pretty tight.