[Solved] Wrt1900acs-v2 to 21.02 - guest dhcp not working

Hi,
I decided to flash the newest firmware (21.02.2) on my wrt1900acs-v2. I'm starting from scratch so as not to make any mistakes with the conversion. I overcame a few hurdles with wireless (yay) and now I'm at the final step of configuring the guest network. I'm using LUCI to do this and have followed this guide: https://openwrt.org/docs/guide-user/network/wifi/guestwifi/configuration_webinterface

The instructions in this guide is very similar to what I did originally. The problem I'm having right now is it's able to connect to wireless, but it's not getting an IP address from DHCP.

/etc/config/wireless

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'     
        option ssid 'GUEST-NETWORK'
        option encryption 'sae-mixed'
        option key 'blah'
        option ieee80211w '0'     
        option network 'guest'

/etc/config/dhcp

config dhcp 'guest'                        
        option interface 'guest'                               
        option start '100'     
        option limit '150'          
        option leasetime '12h'
        list dhcp_option '6,1.1.1.1,8.8.8.8'
        list ra_flags 'none'  

/etc/config/network

type config interface 'guest'    
        option proto 'static'
        option device 'wlan1-1'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

/etc/config/firewall

config zone                  
        option name 'guest'   
        option output 'ACCEPT' 
        option forward 'REJECT'
        list network 'guest'
        option input 'REJECT'

config forwarding
        option src 'guest'
        option dest 'wan'    
                              
config rule                    
        option src 'guest'            
        option dest 'lan'
        option dest_port '53'  
        option target 'ACCEPT' 
        option name 'Guest DNS'
                             
config rule                   
        option name 'Guest DHCP'
        option src 'guest'     
        option dest 'lan'   
        option dest_port '67-68'
        option target 'ACCEPT'

Change your guest rules to option dest β€˜wan’

Done. Unfortunately, still no DHCP ip address. Question: Since the dhcp is coming from the router, can you help me understand why the destination would be set to 'wan'?

Sorry just noticed this:

config zone                  
        option name 'guest'   
        option output 'ACCEPT' 
        option forward 'REJECT'
        list network 'guest'
        option input 'REJECT'

You disabled forwarding/input as well. Set all to ACCEPT.

I got it working. Thanks for your help @RuralRoots . Your suggestions got me thinking and I ended up doing the following:

  1. I left the guest forwarding disabled because I saw it set this way in 2 guides.
  2. I removed the option dest 'lan' from both the 'Guest DNS' rule and the 'Guest DHCP' rule. I noticed I mistakenly added it when it should have been set to the 'device'. Once I did that. the dhcp address worked.

The adjusted lines in /etc/config/firewall look like:

config zone                           
        option name 'guest'           
        option output 'ACCEPT'        
        option forward 'REJECT'
        list network 'guest'          
        option input 'REJECT'  
                                
config rule                     
        option src 'guest'      
        option dest_port '53'   
        option target 'ACCEPT'  
        option name 'Guest DNS' 
                                
config rule                     
        option name 'Guest DHCP'
        option src 'guest'      
        option dest_port '67-68'                    
        option target 'ACCEPT'                      
                                                    
config forwarding                                   
        option src 'guest'                          
        option dest 'wan'                           
1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.