[Solved] WRT1900AC LEDE part boots, stock part bricked, how to flash over stock?

Running a WRT1900AC v1. LEDE in partition 1, partition 2 is bricked.

I tested LEDE out on partition 1 but I'm having too many problems (unable to get over 100mbit links, 5GHz won't start, couple other things) so I tried to switch back to partition 2, which should have had the stock firmware after I confirmed that both partitions were running stock after flashing them both over an existing DD-WRT install prior to LEDE. But when I do either the triple-power-cycle trick or the manual SSH reboot, partition 2 boots but is not accessible at all. The interfaces turn on (the active connections are lit) but the interface times out, SSH times out, DHCP times out... there's no connectivity at all.

How do I really, really forcefully flash over the other partition? I've tried two stock firmware versions, I've retried the ddwrt-to-factory image, and I've even retried flashing DD-WRT onto it, but no matter what I do, sysupgrade -n -F firmware.whatever will go through the motions but it always flashes and boots into the broken 2nd partition.

EDIT: Turns out the stock firmware has to be power cycled after it reboots or else it won't respond. Nice going Linksys. Turns out it was flashing fine the whole time...

There's not that level of instability on the 1900AC v1, which means the issues experienced are due to a select few issues, either:

  • Improperly configured configs
  • A corrupted flash
  • User error

Did you check out the WiFi Troubleshooting in the WRT AC Series wiki?

As to flashing, flashing occurs via a round robin, so if you're booted to the primary partition, flashing would flash the alternate partition and vice versa.

  • As you discovered, the OEM firmware must be allowed to fully boot after a flash, and it takes ~2 - 3min for it to do so. Once the WebUI becomes available, it can be rebooted or switched to the primary/alternate partition.

  • A general FYI: there's a reason It is highly recommended to invest in a USB - TTL cable" is the second bullet down in the Introduction

As to DD-WRT, OpenWrt/LEDE is far more versatile and offers far more to the user than DD-WRT ever has.

  • The issues you experienced are extremely easy to troubleshoot, however it appears they were exacerbated by not reading the device wiki prior to flashing.
    • The device wiki should be the first stop prior to flashing 3rd party firmware to any device.

I went through the docs to try to fix these problems with no results all day. The wiki does not even address these specific issues beyond "check the driver is up to date and post a bug report".

And yes, the OEM firmware not loading correctly after flashing (and thus requiring a manual power cycle) appears to be an actual bug, not just reboot lag. I let it sit for well over 10 minutes with no response until cycled. Obviously this is an OEM issue, not a LEDE issue.

I may return to LEDE in the future but at this time I don't have any reason to use it over the alternatives given these quirks. Thanks for the help anyway.

Did you check the first sub-heading "Missing Drop Down Values"?

The issue is not the firmware, as I just built an image for a WRT1900AC v1 yesterday and it works fine.

  • Did you bother to SSH in and check the system log?

This is one reason why it's recommended to have some way to access the serial console before you flash, as that would have allowed you to view the boot log, thereby showing what was the issue..

You don't know this because you didn't connect via serial to see the log output.

There are no quirks, as the firmware runs just fine.

  • Your issues are a result of doing something incorrectly, whether that be not following the advice laid out under Firmware Images (see verifying hashes), Flashing Firmware, or improperly configured configs.