[Solved] WNDR3800 wont accept firmware

HI all, running into an issue where firmware compiled for Netgear WNDR3800 from trunk will not flash to the unit. TFTP upload results in "transfer successful" but the firmware will not flash (no fast alternating green/orange power light). Just hangs indefinitely after TFTP upload.

Steps to reproduce:

  1. fresh git clone of trunk
  2. make menuconfig and select Target Profile NETGEAR WNDR3800
  3. make defconfig
  4. make

Anyone else having this issue?

I should add that from that same git clone of trunk, I can compile for target UNIFI UAP AC PRO and the resulting firmware flashes and runs just fine on the UniFi.

There should be no problem (but remember that you need to flash the factory image with TFTP).

I have been flashing my WNDR3700v2 regularly and WNDR3800 a while ago.

I was indeed flashing the factory image for the tftp. I pulled down a fresh git clone yesterday and today, same result. Image is accepted by the tftp but never flashes.

Can you upload other WDNR3800 firmwares?
E.g. my community build?

Your 20180212 build for WNDR3800 flashes successfully.

1 Like