[Solved] WNDR3700v2 upgrading LEDE Reboot 17.01.4 -> 18.06.4

How is it possible to upgrade from 17 -> 18 in place without losing my setup?

Is my router capable of running 18.04?


1 Like

Wndr3700v2 runs 18.06 quite nicely, and it also runs 19.07 and master quite ok.

If I remember right, there are no significant differences in config, so a normal sysupgrade works.


Hi @hnyman I was actually hoping you would comment in this thread because of all your great work on this device.

When I go to upgrade using LuCI and the 'Firmware OpenWrt Upgrade URL' ( http://downloads.openwrt.org/releases/18.06.4/targets/ar71xx/generic/openwrt-18.06.4-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin) it complains with:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Any insights would be appreciated.

I used to jump between 17.01 and 18.06 builds with config intact when testing my community build versions. So, keeping settings works.

But it is so long ago from the last time I used 17.01 that it hard to remember details related to the sysupgrade peculiarities for each router that I have...

If I remember right, there was some router id change that prevented smooth sysupgrade to some direction (downgrade from 1806 to 1701 ???).

You might try my community build instead of the official 18.06.4.

Or you might transfer the sysupgrade file to the routers /tmp directory with wget or scp, and then use the console sysupgrade command with the "-F" force option, as 17.01 LuCI does not offer the force option in GUI.

That is of course assuming that you really have 3700v2 so that file is right.

There is always the tftp flash possibility, so you can install the firmware in any case.

Yes looking at the other master thread ( )

It looks like I'm having the same issues as @nieroster
I'll give SCP method a shot, I'm just worried about losing my extroot setup since it's been a long time since I delved into the documentation to set it up.

I'll need to take a look at your community build too, glad to see another nano user.

I also have a WNDR3800 I've thought about switching to, perhaps I can test your community 19 build on it.

That is of course assuming that you really have 3700v2 so that file is right.

Is there any definite way to determine this for certain? I'm going by what LEDE reports from:

cat /proc/cpuinfo

system type             : Atheros AR7161 rev 2
machine                 : NETGEAR WNDR3700/WNDR3800/WNDRMAC
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 452.19
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa                     : mips1 mips2 mips32r1 mips32r2
ASEs implemented        : mips16
shadow register sets    : 1
kscratch registers      : 0
package                 : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

cpuinfo provides no clue, as the variants have the same CPU.

Look at the board data:

root@router2:~# cat /tmp/sysinfo/board_name
root@router2:~# cat /tmp/sysinfo/model

But likely it is just that 17.01 has some ID different than 18.06.4 and that makes sysupgrade board compatibility detection to be picky.

Other option might be to first sysupgrade to the newest 17.01 series release 17.01.6, instead of trying to go from the old 17.01.4 to 18.06.x.

Ps. If you have extroot, you might need to set that up separately in any case. I haven't used it, so I have no firm opinion of its behaviour in sysupgrade.

1 Like

I just tested: I sysupgraded successfully my WNDR3700v2 from 17.01.4 to 18.06.4

I first downgraded from current OpenWrt master ar71xx snapshot to 17.01.4 with sysupgrade from ssh console. No force option was needed. Otherwise smooth sysupgrade, but the wifi config from master did not work immediately (a kernel related device path change, if I remember right...).

Then I sysupgraded from 17.01.4 to 18.06.4 without any trouble. No force option needed there:

   \  DE    \  /    Reboot (17.01.4, r3560-79f57e422d)
    \________\/    -----------------------------------------------------------

root@router2:~# cd /tmp/
root@router2:/tmp# cat /tmp/sysinfo/model
root@router2:/tmp# cat /tmp/sysinfo/board_name
root@router2:/tmp# wget http://downloads.openwrt.org/releases/18.06.4/targets/ar71xx/generic/openwrt-18.06.4-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin
Downloading 'http://downloads.openwrt.org/releases/18.06.4/targets/ar71xx/generic/openwrt-18.06.4-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin'
Connecting to 2a01:4f8:150:6449::2:80
Writing to 'openwrt-18.06.4-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin'
openwrt-18.06.4-ar71 100% |*******************************|  3712k  0:00:00 ETA
Download completed (3801092 bytes)
root@router2:/tmp# sha256sum openwrt-18.06.4-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin
fa29daf1b5477a27e0dac1d061155dc9aa4c74f829f2ae275059b7dc257c8703  openwrt-18.06.4-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin
root@router2:/tmp# sysupgrade /tmp/openwrt-18.06.4-ar71xx-generic-wndr3700v2-squashfs-sysupgrade.bin
Image metadata not found
Saving config files...
killall: watchdog: no process killed
Sending TERM to remaining processes ... odhcp6c ntpd dnsmasq ubusd askfirst logd rpcd netifd odhcpd uhttpd
Sending KILL to remaining processes ... askfirst
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...
Appending jffs2 data from /tmp/sysupgrade.tgz to firmware..                                                    
Upgrade completed
Rebooting system...
umount: can't unmount /dev/pts: Resource busy
umount: can't unmount /dev: Resource busy
umount: can't unmount /tmp: Resource busy

...After flashing completed: a new ssh session: ...

          |__| W I R E L E S S   F R E E D O M
 OpenWrt 18.06.4, r7808-ef686b7292

Ps. note that I did everything from the SSH console. I did not try using LuCI for sysupgrade.

I bricked it..........looks like I'll have an activity for sunday day at least now.

I ended up swapping in my old WNDR3800 that was already running 18.06.4 and factory reset it.
One strange thing I noticed was that I wasn't able to connect upstream to my ISP until I bridged the WAN to eth1, was this necessary to do manually in the past? Have I just forgotten it's been so long?

and for @hnyman

root@OpenWrt:~# cat /tmp/sysinfo/model 
root@OpenWrt:~# cat /tmp/sysinfo/board_name 

Uhmm........and I just noticed I don't have any wifi interfaces......so thats interesting....

My guess is that you have restored some old config and not re-created it after the jump to 18.06. Maybe a conflict between network and firewall config. And wireless has probably a change in the WiFi device path in kernel (like I said above)

It would be better to factory reset it to the defaults and then do the necessary config manually.

Default network config enables wan connectivity without any changes needed.

1 Like

no this is a freshly installed 18.06.4 on a WNDR3800 devices, factory reset no settings kept.

No wifi interfaces at all, lil blurb on the WNDR3800 page says:

Kernel modules

May be need to install WiFi support packages to use WiFi in the Netgerar WRDN3800. Built-in kernel modules of Backfire don't work with WiFi hardware of WNDR3800. If WiFi can't work, you may try following command of uci:

# opkg update
# opkg install kmod-ath9k wpad-mini

Unfortunately that seems to change little

That text has no relevance with the current builds.
"Backfire" was the year 2010 version (10.03 and 10.03.1)

You might try my community build. It has also a 18.06 build from the current head of the 18.06 branch.

I have also the wndr3800 and WiFi works quite ok with the default modules.

hey @hnyman,
I'm trying your 19.07 build and it's failing on uci with this message:

root@OpenWrt:/tmp# sysupgrade -v WNDR3800-owrt1907-r10591-2155e94d4b-20191012-1812-sqfs-sysupgrade.bin
Device wndr3700 not supported by this image
Supported devices: netgear,wndr3800 wndr3800
Image check 'fwtool_check_image' failed.

I'm trying to grab your 18.06 community build now but dropbox link is showing that folder (owrt1806-r7877-6f1a71c2d0-20191004) is empty.

Now the 18.06 files are there. Looks like I had not copied them although I created the directory.

The 19.07 is made with the ath79 target instead of the old ar71xx, so there is device check mismatch in sysupgrade. you need to force that sysupgrade

Finally got the original WNDR3700 reflashed using jtag / serial. Running 18.06.4 now. With Wifi.
what a pain!

root@OpenWrt:~# cat /tmp/sysinfo/model
root@OpenWrt:~# cat /tmp/sysinfo/board_name

So it turns out I was running version 1 all along. Reflashing with v2 is what bricked it.

As you have know since June 2018...
I was trying to find a picture about the WNDR3700v2 label that I took then and sent to the forum, and then I noticed that it was done in a discussion with you :frowning:

I know I KNOW
somewhere along the line I just assumed we had solved that it was a version 2 device from that thread.

Absolute waste of a day.
Really I would have much preferred to switch to the WNDR3800 today and retire this device.
I'll need to diagnose that no wifi interfaces problem seperately, or just consider finally getting a modern router.

Thanks for all your help hnyman..................again.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I marked a post as solved but it won't let me edit the topic to add any additional text.

1 Like