[Solved]Wndr3700 uboot for wndr3800

I would like to do some basic debugging using my 2nd hand wndr3800, however I found that the uboot is replaced to some other customized version, tftp seems not working.
The idea is to flash back to official uboot.
I searched and found only uboot for wndr3700 from https://sourceforge.net/projects/officialnetgearfirmware/files/

I wonder since the hardware between wndr3700 (v1, v2) and wndr3800 has little difference can I flash the wndr3700 uboot to my wndr3800?

Check this: https://www.right.com.cn/forum/thread-151677-1-1.html
You will need to translate from Chinese.

I went through that link, it does not mention anything about uboot difference between wndr3700 and wndr3800.
By the way, the uboot in my router is just their customized. It's good for application puspose, but when I tried to use tftp command it never reaches the host.

WNDR3800 has somewhat newer u-boot than 3700v1.

You can download the original 3800 uboot from my community build's download site. I have stored there the OEM u-boot (mtd0) and u-bootenv (mtd1) binaries of 3700v1, 3700v2 and 3800.

Download site: (see "art partition binary contents" dir)

There are also OpenWrt firmware binaries from 2015, which images have been modified so that it is possible to remove the write-protection from mtd0 and mtd1. (Normally mtd0 and mtd1 are write protected.)


Thank you very much.

I see some hardware has only u-boot in mtd0 but some with u-bootenv in mtd1.
What's the difference between merging and splitting these 2 blocks? Should I flash both of these 2 or only mtd1?

mtd0 u-boot is the actual u-boot binary, while mtd1 is the settings for it. You should at least compare the mtd1 contents, but if I remember right, the mtd1 is actually unused/empty. Check it.

Thank you.
Exactly, I backed up my current full stock and from 0x50000 to 0x70000 are empty.

Hi again,

I flashed mtd0 only and the router can start and work normally.
However when I connected TTL, I found one line from uboot indicate that bad CRC.
How is the CRC calculated?

id read 0x100000ff

flash size 16MB, sector count = 256

Flash: 16 MB

**** Warning - bad CRC, using default environment*

In: serial

Out: serial

Err: serial

Net: ag7100_enet_initialize...

If I remember right, that message is normal with WNDR3800 as the environment is uninitialised/ unused (and u-boot notices that).

I will check when I get home and can see my serial bootlog archive...

This error message means the uboot cannot read saved settings from the settings partition.

You said that mtd1 settings partition is empty, then this message is normal and you can ignore it

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.