[Solved] WLR-8100 bricked


I have the device:


It is catched in a bootloop.

I installed a recent snapshot build and used systemupgrade function from there to install my own build. Obiously I made a mistake in configuration and/or I've overseen some device specific clips. No MAC sounds not good to me. :smiley:

Anyway I thought I can reflash over serial. I tried to access over USB-TTL. But I'm not able to stop/interrupt the boot process to get the tftpt image pushed. My keystrokes are doing nothing. I've tried several settings in putty/minicom. All kinds. -.-
Settings are the usual: 115200 8N1. I tried putty and minicom on linux machine (arch) so far.

Any advise?

My guess is it's either the console settings or the USB-TTL itself. In the wiki there is a line: "using the serial port (3.3V level converter required)". I'm not sure about the meaning of this. I've configured my USB-TTL for 3.3V. The device is a FT232RL chip based (no china fake ^^).


U-Boot 0.0.9 (Feb 18 2013 - 14:56:17)
Product Name: WN-AC1600DGR
ap136 - Scorpion 1.0
Now running in RAM - U-Boot at: 87fc8000
Flash Manuf Id 0xc2, DeviceId0 0x20, DeviceId1 0x18
Flash size 16MB, sector count = 256
In:    serial
Out:   serial
Err:   serial
Multi Net:   


athrs_sgmii_res_cal: cal value = 0xe
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200 
Scorpion  ----> S17 PHY *
: cfg1 0x80000000 cfg2 0x7114
eth0: 00:00:xx:09:xx:xx
athrs17_reg_init: SUPPORT_QCA8337
athrs17_reg_init S17_GLOFW_CTRL1_REG624=7f7f7f7f
athrs17_reg_init: MAC0 RGMII
athrs17_reg_init S17_P0PAD_MODE_REG04=87680000
athrs17_reg_init: Not SGMII_FORCED_MODE
athrs17_reg_init S17_PWS_REG10=40000000
athrs17_reg_init S17_P0STATUS_REG7c=7e
athrs17_reg_init QCA8337 ID=1302
athrs17_reg_init: complete
eth0 up
Setting 0x18116290 to 0x68d0214f

Please choose the operation: 
   1: Load system code to SDRAM via TFTP. 
   3: Boot system code via Flash (default).

**You choosed 3**

3: System Boot system code via Flash.
athrs17_set_portvlan_isolated complete
## Booting image at 9f040000 ...
   Image Name:   MIPS OpenWrt Linux-5.4.52
   Created:      2020-08-17  21:25:41 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    2039955 Bytes =  1.9 MB
   Load Address: 80060000
   Entry Point:  80060000
   Verifying Checksum at 0x9f040040 ...OK
   Uncompressing Kernel Image ... OK

I didn't choose 3 ... Tried 2 and 1 and other keys also.

If you need Kernel Bootlog let me know. I don't think it will not provide anything usefull. Last lines are:

[    1.547965] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.554698] pci 0000:01:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    1.562140] pci 0000:01:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[    1.576025] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    1.588303] Freeing unused kernel memory: 1208K
[    1.592934] This architecture does not have kernel memory protection.
[    1.599488] Run /sbin/init as init process
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@4
[    1.844818] Rebooting in 1 seconds..
  • So you have 3.3 Volt serial connector then; and
  • If so, you're only connecting 3 pins:
    • Tx<>Rx
    • Rx<>Tx
    • and GND<>GND


  • Had you ever tried the serial before?
  • Was it working before?
1 Like

I've tried both. :smiley: I know it's unusual and dangerous with all 4. No difference thats why I was asking if there is sth. special with this device which I'm not aware or understanding.

No I never did it on this specific device before. Other devices are working (checked already on an old wndr3700 if usb-ttl is defect).

Device is:

usb 3-2: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 3-2: Product: FT232R USB UART
ftdi_sio 3-2:1.0: FTDI USB Serial Device converter detected
usb 3-2: Detected FT232RL
usb 3-2: FTDI USB Serial Device converter now attached to ttyUSB0

Maybe I need a different?

Well I'm kind a lost. I can see my keepresses on console but they are not doing anything.

My best guess is I'm to slow. No clue how to fix this because the bootprocess is insanely fast. If that is the reason.

I played a bit around with other serial programs also. No luck. Tried other PCs and cables.

So my latin ends. Which means the graveyard is waiting.

One last question before I give up. Would it make sense to buy another adapter not FT232R based? Like CP2102, PL2303 or CH340? Or is this useless? What adapter you would reccommend?

What could be the reason why tx is working on the Netgear device but not on the Sitecom device? I've tried so many settings and serial consoles so I would say it is not a config/parameter issue.

Finally I got it done. I remembered my RaspberryPI 3 running as DNS resolver dusting in a corner. Got serial working there. Even so it was very very hard to trigger the keys at right moment.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.