[Solved] Wireless works but wired doesn't (OpenWrt 18.06)

I can connect to my router using WiFi with no problems, but a wired connection doesn't work. My router is connecting to a cablemodem which is in bridge mode.

(I would provide more information but I'm not sure what would be useful so please ask for any details!)

Did you look over this thread ?

Otherwise, can you detail your router version ?
Your set-up _ WAN LAN & Configuration

Edit : a wired connection will only work on the LAN of your router (with default config)


thanks for the link, but I still don't have it working.

The router is a TP-Link Archer v5 (EU) that has OpenWRT 18.06.1 on it. I've changed the IP of this to

This is connected to a Netgear CG3100D cablemodem (from my ISP). I can access the config of this at I've turned the WiFi off on this too as I just want to use it as a modem.

I've configured WiFi in OpenWRT and it works, I can connect to it and access the internet.

My PC is connected to the TP-Link router with a cable, but this doesn't let me access the internet.

I can see in the interfaces tab in OpenWRT that the WAN has been assigned an IP of, which I assume comes from my ISP (forgive me if I get any terminology wrong, I'm a n00b in this area!)

When the router had stock firmware on it, I could connect to the internet with a wired connection with no problems - it's only since I installed OpenWRT that it doesn't work, so I'm assuming it's a configuration issue.

Do you need any more details?

Are you sure your Modem is connected to your router on the WAN port ?
Strange to me your modem is / your WAN IP should be similar

What is the IP of your PC when connected through wire to the LAN of your router ?
You can access to the interface of Open WRT
Make sure you are not on on fix IP address out of the range 192.168.2.xx

I'm also n00b with an Archer C7 V5
Maybe a screenshot of the Overview Network

Well that's odd - it's working now! I went away for a while and turned my PC off. When I turned it on again just now, I turned WiFi off (on the PC), and the wired connection works. It's got an IP address of, which is in the range of the router. WiFi still works on other devices too, so at the moment, this is how I want it.... hopefully it'll continue this way!

Thanks for your answers :slight_smile:

@daveh If your problem is solved, please consider marking the topic as [Solved] (Click the pencil behind the topic...).

Ah ok thank you @tmomas, will do!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.