[Solved] Wireless clients fail to obtain ip addresses; tp link archer c7 v3 (with v2 firmware)

SOLVED: Whoops, I needed to attach the wireless config to the lan. I would have liked to see that listed at https://lede-project.org/docs/guide-quick-start/basic_wifi for dummies like myself.


Hi,

I'm new to LEDE and loving it, but haven't gotten wireless working properly yet.

I have 2 active wireless networks configured on the device (2.4 and 5 ghz).

My android phone and linux laptop each fail to obtain ip addresses with either one. Both are wpa2-psk (aes).

Here's NetworkManager's report on a failed attempt:

Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9674] device (wlp4s0): state change: need-auth -> prepare (reason 'none', internal state 'managed')
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9682] device (wlp4s0): state change: prepare -> config (reason 'none', internal state 'managed')
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9686] device (wlp4s0): Activation: (wifi) connection 'The Funhouse [5]' has security, and secrets exist.  No new secrets needed.
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9686] Config: added 'ssid' value 'The Funhouse [5]'
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9686] Config: added 'scan_ssid' value '1'
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9687] Config: added 'key_mgmt' value 'WPA-PSK'
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9687] Config: added 'auth_alg' value 'OPEN'
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9687] Config: added 'psk' value '<hidden>'
Nov 08 22:46:10 Ingram NetworkManager[818]: <info>  [1510199170.9817] device (wlp4s0): supplicant interface state: inactive -> scanning
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8728] device (wlp4s0): supplicant interface state: scanning -> authenticating
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8785] device (wlp4s0): supplicant interface state: authenticating -> associating
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8851] device (wlp4s0): supplicant interface state: associating -> 4-way handshake
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8922] device (wlp4s0): supplicant interface state: 4-way handshake -> completed
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8922] device (wlp4s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'The Funhouse [5]'.
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8923] device (wlp4s0): state change: config -> ip-config (reason 'none', internal state 'managed')
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8926] dhcp4 (wlp4s0): activation: beginning transaction (timeout in 45 seconds)
Nov 08 22:46:11 Ingram NetworkManager[818]: <info>  [1510199171.8939] dhcp4 (wlp4s0): dhclient started with pid 6271
Nov 08 22:46:11 Ingram dhclient[6271]: DHCPDISCOVER on wlp4s0 to 255.255.255.255 port 67 interval 8
Nov 08 22:46:19 Ingram dhclient[6271]: DHCPDISCOVER on wlp4s0 to 255.255.255.255 port 67 interval 12
Nov 08 22:46:31 Ingram dhclient[6271]: DHCPDISCOVER on wlp4s0 to 255.255.255.255 port 67 interval 19
Nov 08 22:46:50 Ingram dhclient[6271]: DHCPDISCOVER on wlp4s0 to 255.255.255.255 port 67 interval 16
Nov 08 22:46:57 Ingram NetworkManager[818]: <warn>  [1510199217.1400] dhcp4 (wlp4s0): request timed out
Nov 08 22:46:57 Ingram NetworkManager[818]: <info>  [1510199217.1401] dhcp4 (wlp4s0): state changed unknown -> timeout
Nov 08 22:46:57 Ingram NetworkManager[818]: <info>  [1510199217.1724] dhcp4 (wlp4s0): canceled DHCP transaction, DHCP client pid 6271
Nov 08 22:46:57 Ingram NetworkManager[818]: <info>  [1510199217.1724] dhcp4 (wlp4s0): state changed timeout -> done
Nov 08 22:46:57 Ingram NetworkManager[818]: <info>  [1510199217.1726] device (wlp4s0): state change: ip-config -> failed (reason 'ip-config-unavailable', internal state 'managed')
Nov 08 22:46:57 Ingram NetworkManager[818]: <warn>  [1510199217.1731] device (wlp4s0): Activation: failed for connection 'The Funhouse [5]'
Nov 08 22:46:57 Ingram NetworkManager[818]: <info>  [1510199217.1830] device (wlp4s0): state change: failed -> disconnected (reason 'none', internal state 'managed')
Nov 08 22:46:57 Ingram NetworkManager[818]: <info>  [1510199217.1903] device (wlp4s0): set-hw-addr: set MAC address to F6:67:C0:1D:41:2B (scanning)
Nov 08 22:46:57 Ingram NetworkManager[818]: <warn>  [1510199217.1925] sup-iface[0x55e6db4b4da0,wlp4s0]: connection disconnected (reason -3)
Nov 08 22:46:57 Ingram NetworkManager[818]: <info>  [1510199217.1928] device (wlp4s0): supplicant interface state: completed -> disconnected

I tried to follow the guide. Could I be missing something? Please let me know if I can be more helpful in my question.

lede-17.01.4-ar71xx-generic-archer-c7-v2-squashfs-factory.bin

have you tried a static ip address? or is this all dhcp?, you could try setting a static ip in luci then manually set that ip on your other device.i had that problem with my iphone setting an ip address manually resolved it for 5ghz

Damn, you're fast. Solved and updated, but thank you very much for responding!

1 Like