[Solved] Wireguard vs OpenConnect - speed comparision

Hi all!

I installed both, ocserv and wireguard packages on my router. Basically I decided to do this because from what I read, Wireguard is “Crème de la crème” when it comes to VPN speed performance and OpenConnect is quite successful when it comes to passing through the great firewall of China. So I thought I would use Wireguard when I’m near home and OpenConnect when I visit China.

However, based on the speed tests I did so far, Wireguard performes much worse compared to OpenConnect. So now I wonder, if perhaps I did something wrong in configuration? Anyway, router is connected to a link speed of 100/10. I performed my measurements using Ookla speed test app on Android device connected via VPN through LTE network.

So here are my measurements:
Cisco AnyConnect VPN client:
Ping: 32ms, Download: 55.5 Mbps, Upload: 4.2 Mbps
Ping: 24ms, Download: 57.1 Mbps, Upload: 6.75 Mbps
Ping: 16ms, Download: 55.0 Mbps, Upload: 6.65 Mbps
Ping: 22ms, Download: 57.5 Mbps, Upload: 4.63 Mbps
Ping: 22ms, Download: 70.9 Mbps, Upload: 6.23 Mbps
Wireguard VPN client:
Ping: 35ms, Download: 14.93 Mbps, Upload: 3.67 Mbps
Ping: 33ms, Download: 14.8 Mbps, Upload: 3.83 Mbps
Ping: 30ms, Download: 14.5 Mbps, Upload: 4.29 Mbps
Ping: 38ms, Download: 14.9 Mbps, Upload: 4.95 Mbps
Ping: 30ms, Download: 14.8 Mbps, Upload: 5.37 Mbps

Is there something I can do to make Wireguard faster? Can’t wait to hear your opinions.

1 Like

CPU maxed out on router? You provided no configs or data.

1 Like

No, CPU is not maxed out neither when using wireguard or openconnect. Here are some configs. If you think anything else would be helpful let me know.

/etc/config/network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd9:b956:b853::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.11.1'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config interface 'wg0'
	option proto 'wireguard'
	option private_key 'xxx'
	option listen_port '51820'
	list addresses '10.10.11.1/24'

config wireguard_wg0
	option public_key 'xxx'
	option persistent_keepalive '25'
	list allowed_ips '10.10.11.2/32'
	option description 'Kompjuter'

config wireguard_wg0
	option description 'Phone'
	list allowed_ips '10.10.11.3/32'
	option public_key 'xxx'
        option persistent_keepalive '25'

/etc/config/firewall


config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone 'lan'
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan wg0'
	list device 'vpns+'

config zone 'wan'
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config include 'bcp38'
	option type 'script'
	option path '/usr/lib/bcp38/run.sh'
	option family 'IPv4'
	option reload '1'

config rule
	option src '*'
	option target 'ACCEPT'
	option proto 'udp'
	option dest_port '51820'
	option name 'Allow-Wireguard'

config rule 'oc'
	option name 'Allow-OpenConnect'
	option src 'wan'
	option dest_port '443'
	option proto 'tcp udp'
	option target 'ACCEPT'

There are some cases when TCP performance is better than UDP.
You can try to compare OpenVPN TCP/UDP on the same hardware.

1 Like

Well OpenConnect actually supports both UDP and TCP and according to my tests UDP is faster. Also the results in first post use UDP.

1 Like

I guess we need more testing, ideally in a local isolated environment.
This is required to exclude external factors and test peak speeds.
Otherwise the current result may not be representative.

Ok, so I repeated the test locally, but I'm still using Ookla speed test app, which I think may be a bad speed indicator in this case. Both VPNs are faster now, the difference between them is much smaller. Sometimes one is faster than the other, but I would say on average OpenConnect is still faster. Ping is always 1 ms for OpenConnect and 1-3 ms for Wireguard. Download speeds are jumping from 30 to 70 Mbps and Upload from 5 to 15 Mbps for both of them. I'll try to find some tool to make a speed test locally, maybe this will give more accurate results.

Ok, so I tried again. This time I used iperf3 between linux and windows machines, both connected with ethernet cables. To run this test I used command "iperf3 -c 192.168.11.93 -t 30 -P 5" on the client side.

Here are the results:

OpenConnect

Connecting to host 192.168.11.93, port 5201
[  4] local 10.10.10.190 port 49725 connected to 192.168.11.93 port 5201
[  6] local 10.10.10.190 port 49726 connected to 192.168.11.93 port 5201
[  8] local 10.10.10.190 port 49727 connected to 192.168.11.93 port 5201
[ 10] local 10.10.10.190 port 49728 connected to 192.168.11.93 port 5201
[ 12] local 10.10.10.190 port 49730 connected to 192.168.11.93 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  1.12 MBytes  9.42 Mbits/sec                  
[  6]   0.00-1.00   sec  1.12 MBytes  9.42 Mbits/sec                  
[  8]   0.00-1.00   sec  1.00 MBytes  8.38 Mbits/sec                  
[ 10]   0.00-1.00   sec  1.00 MBytes  8.38 Mbits/sec                  
[ 12]   0.00-1.00   sec  1.00 MBytes  8.38 Mbits/sec                  
[SUM]   0.00-1.00   sec  5.25 MBytes  44.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   1.00-2.00   sec  2.25 MBytes  18.9 Mbits/sec                  
[  6]   1.00-2.00   sec  2.25 MBytes  18.9 Mbits/sec                  
[  8]   1.00-2.00   sec  2.38 MBytes  19.9 Mbits/sec                  
[ 10]   1.00-2.00   sec  2.38 MBytes  19.9 Mbits/sec                  
[ 12]   1.00-2.00   sec  2.38 MBytes  19.9 Mbits/sec                  
[SUM]   1.00-2.00   sec  11.6 MBytes  97.6 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   2.00-3.00   sec  0.00 Bytes  0.00 bits/sec                  
[  6]   2.00-3.00   sec  0.00 Bytes  0.00 bits/sec                  
[  8]   2.00-3.00   sec  1.12 MBytes  9.44 Mbits/sec                  
[ 10]   2.00-3.00   sec  1.12 MBytes  9.44 Mbits/sec                  
[ 12]   2.00-3.00   sec  1.12 MBytes  9.44 Mbits/sec                  
[SUM]   2.00-3.00   sec  3.38 MBytes  28.3 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   3.00-4.00   sec   768 KBytes  6.29 Mbits/sec                  
[  6]   3.00-4.00   sec   896 KBytes  7.33 Mbits/sec                  
[  8]   3.00-4.00   sec  1.12 MBytes  9.43 Mbits/sec                  
[ 10]   3.00-4.00   sec  1.25 MBytes  10.5 Mbits/sec                  
[ 12]   3.00-4.00   sec  2.75 MBytes  23.0 Mbits/sec                  
[SUM]   3.00-4.00   sec  6.75 MBytes  56.6 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   4.00-5.00   sec  1.00 MBytes  8.40 Mbits/sec                  
[  6]   4.00-5.00   sec  1.12 MBytes  9.44 Mbits/sec                  
[  8]   4.00-5.00   sec  1.25 MBytes  10.5 Mbits/sec                  
[ 10]   4.00-5.00   sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]   4.00-5.00   sec  3.25 MBytes  27.3 Mbits/sec                  
[SUM]   4.00-5.00   sec  8.12 MBytes  68.2 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   5.00-6.00   sec   896 KBytes  7.34 Mbits/sec                  
[  6]   5.00-6.00   sec  1.00 MBytes  8.39 Mbits/sec                  
[  8]   5.00-6.00   sec  1.25 MBytes  10.5 Mbits/sec                  
[ 10]   5.00-6.00   sec  1.38 MBytes  11.5 Mbits/sec                  
[ 12]   5.00-6.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[SUM]   5.00-6.00   sec  7.50 MBytes  62.9 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   6.00-7.00   sec   896 KBytes  7.34 Mbits/sec                  
[  6]   6.00-7.00   sec  1.00 MBytes  8.39 Mbits/sec                  
[  8]   6.00-7.00   sec  1.38 MBytes  11.5 Mbits/sec                  
[ 10]   6.00-7.00   sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]   6.00-7.00   sec  3.12 MBytes  26.2 Mbits/sec                  
[SUM]   6.00-7.00   sec  7.88 MBytes  66.1 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   7.00-8.00   sec  1.00 MBytes  8.38 Mbits/sec                  
[  6]   7.00-8.00   sec  1.00 MBytes  8.38 Mbits/sec                  
[  8]   7.00-8.00   sec  1.38 MBytes  11.5 Mbits/sec                  
[ 10]   7.00-8.00   sec  1.38 MBytes  11.5 Mbits/sec                  
[ 12]   7.00-8.00   sec  2.75 MBytes  23.0 Mbits/sec                  
[SUM]   7.00-8.00   sec  7.50 MBytes  62.8 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   8.00-9.00   sec  1.00 MBytes  8.39 Mbits/sec                  
[  6]   8.00-9.00   sec  1.12 MBytes  9.44 Mbits/sec                  
[  8]   8.00-9.00   sec  1.38 MBytes  11.5 Mbits/sec                  
[ 10]   8.00-9.00   sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]   8.00-9.00   sec  2.62 MBytes  22.0 Mbits/sec                  
[SUM]   8.00-9.00   sec  7.62 MBytes  64.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   9.00-10.00  sec  1.38 MBytes  11.6 Mbits/sec                  
[  6]   9.00-10.00  sec  1.38 MBytes  11.6 Mbits/sec                  
[  8]   9.00-10.00  sec  1.62 MBytes  13.7 Mbits/sec                  
[ 10]   9.00-10.00  sec  1.88 MBytes  15.8 Mbits/sec                  
[ 12]   9.00-10.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[SUM]   9.00-10.00  sec  9.50 MBytes  79.8 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  10.00-11.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[  6]  10.00-11.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  8]  10.00-11.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[ 10]  10.00-11.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]  10.00-11.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[SUM]  10.00-11.00  sec  8.50 MBytes  71.3 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  11.00-12.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  6]  11.00-12.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  8]  11.00-12.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[ 10]  11.00-12.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[ 12]  11.00-12.00  sec  1.88 MBytes  15.7 Mbits/sec                  
[SUM]  11.00-12.00  sec  8.12 MBytes  68.2 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  12.00-13.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[  6]  12.00-13.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[  8]  12.00-13.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 10]  12.00-13.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[ 12]  12.00-13.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[SUM]  12.00-13.00  sec  6.75 MBytes  56.6 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  13.00-14.00  sec  1.12 MBytes  9.45 Mbits/sec                  
[  6]  13.00-14.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  8]  13.00-14.00  sec  1.88 MBytes  15.7 Mbits/sec                  
[ 10]  13.00-14.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[ 12]  13.00-14.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[SUM]  13.00-14.00  sec  7.50 MBytes  63.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  14.00-15.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[  6]  14.00-15.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  8]  14.00-15.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[ 10]  14.00-15.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[ 12]  14.00-15.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[SUM]  14.00-15.00  sec  7.88 MBytes  66.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  15.00-16.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  6]  15.00-16.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  8]  15.00-16.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 10]  15.00-16.00  sec  2.12 MBytes  17.8 Mbits/sec                  
[ 12]  15.00-16.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[SUM]  15.00-16.00  sec  8.75 MBytes  73.4 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  16.00-17.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[  6]  16.00-17.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[  8]  16.00-17.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[ 10]  16.00-17.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 12]  16.00-17.00  sec  2.38 MBytes  19.9 Mbits/sec                  
[SUM]  16.00-17.00  sec  8.38 MBytes  70.2 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  17.00-18.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  6]  17.00-18.00  sec  1.38 MBytes  11.6 Mbits/sec                  
[  8]  17.00-18.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[ 10]  17.00-18.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 12]  17.00-18.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[SUM]  17.00-18.00  sec  7.62 MBytes  64.1 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  18.00-19.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[  6]  18.00-19.00  sec  1.88 MBytes  15.7 Mbits/sec                  
[  8]  18.00-19.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[ 10]  18.00-19.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[ 12]  18.00-19.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[SUM]  18.00-19.00  sec  7.50 MBytes  62.9 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  19.00-20.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  6]  19.00-20.00  sec  1.88 MBytes  15.7 Mbits/sec                  
[  8]  19.00-20.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[ 10]  19.00-20.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 12]  19.00-20.00  sec  1.88 MBytes  15.7 Mbits/sec                  
[SUM]  19.00-20.00  sec  8.12 MBytes  68.2 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  20.00-21.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[  6]  20.00-21.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[  8]  20.00-21.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[ 10]  20.00-21.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 12]  20.00-21.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[SUM]  20.00-21.00  sec  7.62 MBytes  63.9 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  21.00-22.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  6]  21.00-22.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[  8]  21.00-22.00  sec  1.12 MBytes  9.44 Mbits/sec                  
[ 10]  21.00-22.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[ 12]  21.00-22.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[SUM]  21.00-22.00  sec  7.38 MBytes  61.9 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  22.00-23.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  6]  22.00-23.00  sec  1.88 MBytes  15.7 Mbits/sec                  
[  8]  22.00-23.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[ 10]  22.00-23.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]  22.00-23.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[SUM]  22.00-23.00  sec  7.75 MBytes  65.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  23.00-24.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  6]  23.00-24.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[  8]  23.00-24.00  sec  1.12 MBytes  9.45 Mbits/sec                  
[ 10]  23.00-24.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]  23.00-24.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[SUM]  23.00-24.00  sec  7.38 MBytes  61.9 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  24.00-25.00  sec   896 KBytes  7.33 Mbits/sec                  
[  6]  24.00-25.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  8]  24.00-25.00  sec  1.00 MBytes  8.38 Mbits/sec                  
[ 10]  24.00-25.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[ 12]  24.00-25.00  sec  1.12 MBytes  9.43 Mbits/sec                  
[SUM]  24.00-25.00  sec  5.38 MBytes  45.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  25.00-26.00  sec   640 KBytes  5.25 Mbits/sec                  
[  6]  25.00-26.00  sec  1.00 MBytes  8.40 Mbits/sec                  
[  8]  25.00-26.00  sec   512 KBytes  4.20 Mbits/sec                  
[ 10]  25.00-26.00  sec   512 KBytes  4.20 Mbits/sec                  
[ 12]  25.00-26.00  sec   896 KBytes  7.35 Mbits/sec                  
[SUM]  25.00-26.00  sec  3.50 MBytes  29.4 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  26.00-27.00  sec   896 KBytes  7.33 Mbits/sec                  
[  6]  26.00-27.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  8]  26.00-27.00  sec   896 KBytes  7.33 Mbits/sec                  
[ 10]  26.00-27.00  sec  1.00 MBytes  8.38 Mbits/sec                  
[ 12]  26.00-27.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[SUM]  26.00-27.00  sec  5.25 MBytes  44.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  27.00-28.00  sec  1.38 MBytes  11.5 Mbits/sec                  
[  6]  27.00-28.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[  8]  27.00-28.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[ 10]  27.00-28.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]  27.00-28.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[SUM]  27.00-28.00  sec  7.88 MBytes  66.1 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  28.00-29.00  sec  1.25 MBytes  10.5 Mbits/sec                  
[  6]  28.00-29.00  sec  1.62 MBytes  13.6 Mbits/sec                  
[  8]  28.00-29.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 10]  28.00-29.00  sec  1.50 MBytes  12.6 Mbits/sec                  
[ 12]  28.00-29.00  sec  2.12 MBytes  17.8 Mbits/sec                  
[SUM]  28.00-29.00  sec  8.25 MBytes  69.1 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  29.00-30.00  sec  1.12 MBytes  9.45 Mbits/sec                  
[  6]  29.00-30.00  sec  1.62 MBytes  13.7 Mbits/sec                  
[  8]  29.00-30.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 10]  29.00-30.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[ 12]  29.00-30.00  sec  1.75 MBytes  14.7 Mbits/sec                  
[SUM]  29.00-30.00  sec  8.00 MBytes  67.2 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-30.00  sec  34.5 MBytes  9.65 Mbits/sec                  sender
[  4]   0.00-30.00  sec  34.3 MBytes  9.58 Mbits/sec                  receiver
[  6]   0.00-30.00  sec  40.4 MBytes  11.3 Mbits/sec                  sender
[  6]   0.00-30.00  sec  40.1 MBytes  11.2 Mbits/sec                  receiver
[  8]   0.00-30.00  sec  43.0 MBytes  12.0 Mbits/sec                  sender
[  8]   0.00-30.00  sec  42.7 MBytes  11.9 Mbits/sec                  receiver
[ 10]   0.00-30.00  sec  44.6 MBytes  12.5 Mbits/sec                  sender
[ 10]   0.00-30.00  sec  44.4 MBytes  12.4 Mbits/sec                  receiver
[ 12]   0.00-30.00  sec  60.1 MBytes  16.8 Mbits/sec                  sender
[ 12]   0.00-30.00  sec  59.9 MBytes  16.8 Mbits/sec                  receiver
[SUM]   0.00-30.00  sec   223 MBytes  62.3 Mbits/sec                  sender
[SUM]   0.00-30.00  sec   221 MBytes  61.9 Mbits/sec                  receiver

iperf Done.

Wireguard

Connecting to host 192.168.11.93, port 5201
[  4] local 10.10.11.2 port 49943 connected to 192.168.11.93 port 5201
[  6] local 10.10.11.2 port 49944 connected to 192.168.11.93 port 5201
[  8] local 10.10.11.2 port 49945 connected to 192.168.11.93 port 5201
[ 10] local 10.10.11.2 port 49946 connected to 192.168.11.93 port 5201
[ 12] local 10.10.11.2 port 49947 connected to 192.168.11.93 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  2.38 MBytes  19.9 Mbits/sec                  
[  6]   0.00-1.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[  8]   0.00-1.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[ 10]   0.00-1.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[ 12]   0.00-1.00   sec  3.50 MBytes  29.3 Mbits/sec                  
[SUM]   0.00-1.00   sec  14.9 MBytes   125 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   1.00-2.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[  6]   1.00-2.00   sec  3.25 MBytes  27.3 Mbits/sec                  
[  8]   1.00-2.00   sec  3.25 MBytes  27.3 Mbits/sec                  
[ 10]   1.00-2.00   sec  3.25 MBytes  27.3 Mbits/sec                  
[ 12]   1.00-2.00   sec  3.38 MBytes  28.3 Mbits/sec                  
[SUM]   1.00-2.00   sec  16.1 MBytes   135 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   2.00-3.00   sec  3.75 MBytes  31.5 Mbits/sec                  
[  6]   2.00-3.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[  8]   2.00-3.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[ 10]   2.00-3.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[ 12]   2.00-3.00   sec  3.62 MBytes  30.4 Mbits/sec                  
[SUM]   2.00-3.00   sec  17.9 MBytes   150 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   3.00-4.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[  6]   3.00-4.00   sec  3.75 MBytes  31.5 Mbits/sec                  
[  8]   3.00-4.00   sec  3.75 MBytes  31.5 Mbits/sec                  
[ 10]   3.00-4.00   sec  3.75 MBytes  31.5 Mbits/sec                  
[ 12]   3.00-4.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[SUM]   3.00-4.00   sec  18.2 MBytes   153 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   4.00-5.00   sec  2.75 MBytes  23.1 Mbits/sec                  
[  6]   4.00-5.00   sec  2.75 MBytes  23.1 Mbits/sec                  
[  8]   4.00-5.00   sec  2.75 MBytes  23.1 Mbits/sec                  
[ 10]   4.00-5.00   sec  2.75 MBytes  23.1 Mbits/sec                  
[ 12]   4.00-5.00   sec  2.88 MBytes  24.1 Mbits/sec                  
[SUM]   4.00-5.00   sec  13.9 MBytes   116 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   5.00-6.00   sec  2.75 MBytes  23.0 Mbits/sec                  
[  6]   5.00-6.00   sec  2.75 MBytes  23.0 Mbits/sec                  
[  8]   5.00-6.00   sec  2.75 MBytes  23.0 Mbits/sec                  
[ 10]   5.00-6.00   sec  2.75 MBytes  23.0 Mbits/sec                  
[ 12]   5.00-6.00   sec  2.75 MBytes  23.0 Mbits/sec                  
[SUM]   5.00-6.00   sec  13.8 MBytes   115 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   6.00-7.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[  6]   6.00-7.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[  8]   6.00-7.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[ 10]   6.00-7.00   sec  3.50 MBytes  29.4 Mbits/sec                  
[ 12]   6.00-7.00   sec  3.62 MBytes  30.4 Mbits/sec                  
[SUM]   6.00-7.00   sec  17.6 MBytes   148 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   7.00-8.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[  6]   7.00-8.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[  8]   7.00-8.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[ 10]   7.00-8.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[ 12]   7.00-8.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[SUM]   7.00-8.00   sec  15.0 MBytes   126 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   8.00-9.00   sec  3.25 MBytes  27.3 Mbits/sec                  
[  6]   8.00-9.00   sec  3.25 MBytes  27.3 Mbits/sec                  
[  8]   8.00-9.00   sec  3.25 MBytes  27.3 Mbits/sec                  
[ 10]   8.00-9.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[ 12]   8.00-9.00   sec  3.00 MBytes  25.2 Mbits/sec                  
[SUM]   8.00-9.00   sec  15.8 MBytes   132 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   9.00-10.00  sec  3.25 MBytes  27.2 Mbits/sec                  
[  6]   9.00-10.00  sec  3.00 MBytes  25.1 Mbits/sec                  
[  8]   9.00-10.00  sec  3.00 MBytes  25.1 Mbits/sec                  
[ 10]   9.00-10.00  sec  3.25 MBytes  27.2 Mbits/sec                  
[ 12]   9.00-10.00  sec  3.25 MBytes  27.2 Mbits/sec                  
[SUM]   9.00-10.00  sec  15.8 MBytes   132 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  10.00-11.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[  6]  10.00-11.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[  8]  10.00-11.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[ 10]  10.00-11.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[ 12]  10.00-11.00  sec  2.00 MBytes  16.8 Mbits/sec                  
[SUM]  10.00-11.00  sec  10.2 MBytes  86.0 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  11.00-12.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[  6]  11.00-12.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[  8]  11.00-12.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[ 10]  11.00-12.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[ 12]  11.00-12.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[SUM]  11.00-12.00  sec  13.2 MBytes   111 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  12.00-13.00  sec  3.75 MBytes  31.5 Mbits/sec                  
[  6]  12.00-13.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[  8]  12.00-13.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[ 10]  12.00-13.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[ 12]  12.00-13.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[SUM]  12.00-13.00  sec  17.8 MBytes   149 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  13.00-14.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[  6]  13.00-14.00  sec  3.00 MBytes  25.1 Mbits/sec                  
[  8]  13.00-14.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[ 10]  13.00-14.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[ 12]  13.00-14.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[SUM]  13.00-14.00  sec  14.0 MBytes   117 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  14.00-15.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[  6]  14.00-15.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[  8]  14.00-15.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 10]  14.00-15.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 12]  14.00-15.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[SUM]  14.00-15.00  sec  15.0 MBytes   126 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  15.00-16.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[  6]  15.00-16.00  sec  3.38 MBytes  28.3 Mbits/sec                  
[  8]  15.00-16.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[ 10]  15.00-16.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[ 12]  15.00-16.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[SUM]  15.00-16.00  sec  17.4 MBytes   146 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  16.00-17.00  sec  4.00 MBytes  33.6 Mbits/sec                  
[  6]  16.00-17.00  sec  4.12 MBytes  34.6 Mbits/sec                  
[  8]  16.00-17.00  sec  4.25 MBytes  35.7 Mbits/sec                  
[ 10]  16.00-17.00  sec  4.00 MBytes  33.6 Mbits/sec                  
[ 12]  16.00-17.00  sec  4.00 MBytes  33.6 Mbits/sec                  
[SUM]  16.00-17.00  sec  20.4 MBytes   171 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  17.00-18.00  sec  3.50 MBytes  29.3 Mbits/sec                  
[  6]  17.00-18.00  sec  3.50 MBytes  29.3 Mbits/sec                  
[  8]  17.00-18.00  sec  3.25 MBytes  27.2 Mbits/sec                  
[ 10]  17.00-18.00  sec  3.50 MBytes  29.3 Mbits/sec                  
[ 12]  17.00-18.00  sec  3.50 MBytes  29.3 Mbits/sec                  
[SUM]  17.00-18.00  sec  17.2 MBytes   145 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  18.00-19.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[  6]  18.00-19.00  sec  3.12 MBytes  26.2 Mbits/sec                  
[  8]  18.00-19.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 10]  18.00-19.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 12]  18.00-19.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[SUM]  18.00-19.00  sec  16.1 MBytes   135 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  19.00-20.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[  6]  19.00-20.00  sec  3.12 MBytes  26.2 Mbits/sec                  
[  8]  19.00-20.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 10]  19.00-20.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 12]  19.00-20.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[SUM]  19.00-20.00  sec  16.1 MBytes   135 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  20.00-21.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[  6]  20.00-21.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[  8]  20.00-21.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 10]  20.00-21.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 12]  20.00-21.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[SUM]  20.00-21.00  sec  15.0 MBytes   126 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  21.00-22.00  sec  3.50 MBytes  29.3 Mbits/sec                  
[  6]  21.00-22.00  sec  3.75 MBytes  31.4 Mbits/sec                  
[  8]  21.00-22.00  sec  3.75 MBytes  31.4 Mbits/sec                  
[ 10]  21.00-22.00  sec  3.75 MBytes  31.4 Mbits/sec                  
[ 12]  21.00-22.00  sec  3.50 MBytes  29.3 Mbits/sec                  
[SUM]  21.00-22.00  sec  18.2 MBytes   153 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  22.00-23.00  sec  2.62 MBytes  22.0 Mbits/sec                  
[  6]  22.00-23.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[  8]  22.00-23.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[ 10]  22.00-23.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[ 12]  22.00-23.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[SUM]  22.00-23.00  sec  12.9 MBytes   108 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  23.00-24.00  sec  2.88 MBytes  24.1 Mbits/sec                  
[  6]  23.00-24.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[  8]  23.00-24.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 10]  23.00-24.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 12]  23.00-24.00  sec  2.88 MBytes  24.1 Mbits/sec                  
[SUM]  23.00-24.00  sec  14.8 MBytes   124 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  24.00-25.00  sec  3.50 MBytes  29.4 Mbits/sec                  
[  6]  24.00-25.00  sec  3.38 MBytes  28.3 Mbits/sec                  
[  8]  24.00-25.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 10]  24.00-25.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 12]  24.00-25.00  sec  3.38 MBytes  28.3 Mbits/sec                  
[SUM]  24.00-25.00  sec  16.8 MBytes   141 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  25.00-26.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[  6]  25.00-26.00  sec  2.62 MBytes  22.0 Mbits/sec                  
[  8]  25.00-26.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[ 10]  25.00-26.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[ 12]  25.00-26.00  sec  2.50 MBytes  21.0 Mbits/sec                  
[SUM]  25.00-26.00  sec  12.9 MBytes   108 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  26.00-27.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[  6]  26.00-27.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[  8]  26.00-27.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 10]  26.00-27.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 12]  26.00-27.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[SUM]  26.00-27.00  sec  15.8 MBytes   132 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  27.00-28.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[  6]  27.00-28.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[  8]  27.00-28.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 10]  27.00-28.00  sec  3.00 MBytes  25.2 Mbits/sec                  
[ 12]  27.00-28.00  sec  2.75 MBytes  23.1 Mbits/sec                  
[SUM]  27.00-28.00  sec  14.5 MBytes   122 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  28.00-29.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[  6]  28.00-29.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[  8]  28.00-29.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[ 10]  28.00-29.00  sec  2.12 MBytes  17.8 Mbits/sec                  
[ 12]  28.00-29.00  sec  2.25 MBytes  18.9 Mbits/sec                  
[SUM]  28.00-29.00  sec  11.1 MBytes  93.2 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]  29.00-30.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[  6]  29.00-30.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[  8]  29.00-30.00  sec  3.25 MBytes  27.3 Mbits/sec                  
[ 10]  29.00-30.00  sec  3.38 MBytes  28.4 Mbits/sec                  
[ 12]  29.00-30.00  sec  3.38 MBytes  28.4 Mbits/sec                  
[SUM]  29.00-30.00  sec  16.5 MBytes   139 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-30.00  sec  92.1 MBytes  25.8 Mbits/sec                  sender
[  4]   0.00-30.00  sec  92.1 MBytes  25.8 Mbits/sec                  receiver
[  6]   0.00-30.00  sec  93.0 MBytes  26.0 Mbits/sec                  sender
[  6]   0.00-30.00  sec  93.0 MBytes  26.0 Mbits/sec                  receiver
[  8]   0.00-30.00  sec  93.0 MBytes  26.0 Mbits/sec                  sender
[  8]   0.00-30.00  sec  93.0 MBytes  26.0 Mbits/sec                  receiver
[ 10]   0.00-30.00  sec  93.0 MBytes  26.0 Mbits/sec                  sender
[ 10]   0.00-30.00  sec  93.0 MBytes  26.0 Mbits/sec                  receiver
[ 12]   0.00-30.00  sec  93.6 MBytes  26.2 Mbits/sec                  sender
[ 12]   0.00-30.00  sec  93.6 MBytes  26.2 Mbits/sec                  receiver
[SUM]   0.00-30.00  sec   465 MBytes   130 Mbits/sec                  sender
[SUM]   0.00-30.00  sec   465 MBytes   130 Mbits/sec                  receiver

iperf Done.

This time Wireguard was more than twice as fast compared to OpenConnect. :face_with_raised_eyebrow:

1 Like

So, the initial test results seem to be affected by some external factors.
You can try changing the WG port to 443 and optimizing MTU on the WG interface.

I already tried both before but it did not seem to help. Although to be honest, beside the default MTU value, the only other one I tested was 1280, which is the lowest it allowed me to input. I'll try to play with it again. Do you have any idea what kind of MTU values could improve situation?

You could try going back to 1420, and reducing it little by little to see if it has any effect on throughput. 1420 covers Wireguard + Ethernet and IPv4/6 overhead. For LTE, maybe try 1420 - 64 bytes (1356) and see what happens to the transfer speeds.

2 Likes

It's probably because the Android version of the Wireguard client uses a userspace implementation unless you're using an Android build that includes the kernel modules for wireguard.

Says so here on their gitpage.

4 Likes

Looks like you are right. I tried different ports and MTU values, but it doesn't feel like performance would improve. So I guess the problem really is with how Android app works. I hope eventually they will find a way to make this work on Android as well. Until then, we will just have to use slower speeds.

Thanks guys for all of the ideas that you contributed.

For some reason I can't edit the title to add [Solved] in front of it. Unless anyone knows what to do, I'll just leave it as it is?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.