[Solved] Will there be any pitfalls with an 8TB drive?

Currently, I have a 1.92TB SSD connected to my Netgear R7800 router via USB-SATA adapter. The drive is formatted as ext4 and shared via SAMBA. However, there's only 200 GB left free.

There is an 8TB SSD on sale right now (I cannot tolerate HDD noise), and I consider buying it as a replacement. Does anyone else have any experience using such large disks with OpenWRT? Are there any pitfalls that I should be aware of?

assuming you use ext4, all pitfalls pretty much boil down to


  • form factor and aesthetic
  • max size supported
  • powered vs non powered
  • whether it auto 'spins down' or not
  • uasp support or other related specification/revision bottleneck gotcha's

etc. etc. and whether it overheats your routers parts on sustained throughput

1 Like

At some point (and -imho- considering the disk size and SSD prices for this volume, we're way past that point), more suited hardware (NAS/ fileserver) might become a better option - from a purely hardware/ performance centric point of view. Because of this particular usage scenario and the maximum networking throughput possible (1 GBit/s, effectively considerably less), going with an SSD doesn't really make sense either.


This ^^^

Let the router be a router.

1 Like

R7800 has an esata port seems weird using a usb to sata when native stat is there

& some point you will rum out of ram for buffering and i think will slow down

The eSATA port provides no power, and I don't know what kind of cable I need to use a "normal" SATA SSD with it.

it's the same as USB
+5V is there so laptop drives & SSD 's are fine
3.5' desktop drives you need a powered enclosure
don't forget Esata is also a usb 2.0 port

OK, ordered this cable, will test it with the existing SSD.

1 Like

If you plan to create one large partition with 8TB (or generally a partition > 2TB), you must define it as a GPT partition. This is not really a pitfall, but a GPT partition is necessary for ordinary work.

Well, this is the wrong cable (doesn't fit the eSATA socket), and therefore I still don't know which cable should be used to connect a normal SATA SSD to the eSATA port present on the R7800.

from the picture it look's like the same ends I use n my EA8500
witch i was expecting to be the same
I have only seen one type
my linksys EA8500 is the same as my laptop
& my old desktop's mother board's atx connectors
I use the same cable for all 3 with an old WD 750G black laptop drive & other SSD's

Fiddlesticks. I have a far less capable R7000 that has an 8tb drive. Now it's just a physical Seagate archive drive, but it's perfectly reasonable to use these little devices like this. My little "router" also runs syncthing as the hub for all my data sharing, is my home's DLNA server, and it reaches out to my real-world Debian 11 server to grab database backups for all my web sites too.

Call shenanigans on this.

Works great. Besides the already mentioned GPT partition table which may be needed.

Nope. Even your USB-SATA adapter is fine. The OCD purist in all of us answering in this thread would love to see you get it working on the eSATA, but from a performance standpoint (the sort of data speeds you're going to get over the air with this) it's not really relevant. If you are putting swap space on this drive, maaayyybe I'd push harder to get eSATA working.

Don't let anyone lead you to believe your device is not more than capable of what you're asking. The traffic for your "NAS" would be carried by the router anyway. The extra bit bashing of having the router grab the data from a drive is negligable.

You do you.

1 Like

The drive (Samsung 970 QVO) has finally arrived. It works, but I did have to buy a new USB-SATA enclosure. The old one was not even appearing in lsusb with the new SSD inside (even on my laptop), maybe because it has a 2TB drive size limit.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.