[Solved]Will OpenWrt handle local DNS?

My old WRT54GL flashed with Tomato had a kind of local DNS service. I wrote backup scripts on a server to check which of my multi-boot OS's was active and to proceed accordingly. These scripts rely on local DNS recognition as does ssh and others. My system long ago became too complex to easily use the /etc/hosts file for this purpose.

I bought a Netgear r7800 based on recommendations here and it seems to be a nice router. I replaced my old router with the r7800 yesterday, but haven't yet flashed it with OpenWrt. My question is in the subject: will OpenWrt handle my local DNS needs? If so, can you point me to some documentation? If not, I suppose I may have to install bind on my debian server and use that for local machine recognition. Any opinions on the best way to address this?

btw, as some have said when I was asking about hardware, the r7800 is more than 50% faster in download speeds than the old Linksys.

Pretty sure yes, unless you provide a reason against it.


dnsmasq serves most peoples needs, and in a lot of cases does even more than that....

dns, dhcp, ipsets ( expedite qos and other services ), tftpd, ntp?

bind is in the package repositories, as are others, and maybe in less than 10% of cases, situation might need advanced nameserver features. although you'll pay for the jump in configuration overhead.

so short answer, yes like @vgaetera says. when this question arises, list specifics... local dns as you mention scripts calling could mean anything. frequency, quantity any other fancy uses for dns?

eitherway, you'll find out pretty quickly as basic setup is almost non-necessary.

-install htop or just use ntop and watch it..... check in every day..... for a few days
-do the same with a debian alternative / vm......
-not happy then switch the service over.... leaves a bit more overhead for vpn / qos / iptables etc. etc.
-change your scripts or static out the most demanding parts

Installed OpenWrt a few days ago. For now going with dnsmasq, and reserved IPs for those machines (or multi-boot OSes) that need them (for unattended backup, ssh etc). Working, but not all the wrinkles ironed out. When pinging inside the LAN using machine names, all pings get through, but some show the correct IP of the pinged device while others show something like, "(fd5b:a57f:3f15::d00)" wondering why?

1 Like

That's an IPv6 address. If your network is IPv4 only, turn off the IPv6 features in /etc/config/dhcp.

@feffer777 or better yet, consider that ipv6 is generally fabulous compared to ipv4 and start using ipv6 for your infrastructure. Learning about ipv6 is relatively easy with HE's certification/tutorial https://ipv6.he.net/certification/ with some online tutorials, try googling I don't really have a best suggestion. HE is fine as certification thingy, but the actual training material is something to be desired.

Here's one set of training info: https://www.internetsociety.org/deploy360/ipv6/training/

and another: http://www.ipv6now.com.au/tutorials.php

Haven't used those but they look relatively complete in terms of what they discuss.


Modern OS prefer IPv6 provided sufficient connectivity.
Do not shoot yourself in your foot trying to disable it.

1 Like

Yah, I'll try using IPv4 only to stop the mixed results. Also disconcerting were the time diffs:

PING ubunac(ubunac.lan (fd5b:a57f:3f15::d00)) 56 data bytes
64 bytes from ubunac.lan (fd5b:a57f:3f15::d00): icmp_seq=1 ttl=64 time=39.6 ms
64 bytes from ubunac.lan (fd5b:a57f:3f15::d00): icmp_seq=2 ttl=64 time=1.76 ms
64 bytes from ubunac.lan (fd5b:a57f:3f15::d00): icmp_seq=3 ttl=64 time=2.43 ms
64 bytes from ubunac.lan (fd5b:a57f:3f15::d00): icmp_seq=4 ttl=64 time=2.06 ms
64 bytes from ubunac.lan (fd5b:a57f:3f15::d00): icmp_seq=5 ttl=64 time=2.06 ms
64 bytes from ubunac.lan (fd5b:a57f:3f15::d00): icmp_seq=6 ttl=64 time=149 ms

Hmmm, after poking around, I do not see where I can turn off IPv6 for the LAN?

On the LAN Interface settings in the LuCI web GUI:



Thx, I went to Network > Interfaces before posting, but did not see anything obvious. "disabled" choices there afterall.

OK, after fixing that my LAN had only IPv4 (had to reboot my debian box...somehow it was holding onto IPv6) Also my ping times are consistent within wired devices...a bit erratic on wifi ones...but then again my wife is streaming a movie...so to be expected.

1 Like

OK, thx to all. Shut off IPv6 so my LAN is only using IPv4. Unattended backup scripts for multi-boot machines now working properly. Very happy with OpenWrt! Some said IPv6 fits better with modern OSes. For now, keeping an IPv4 LAN makes life simpler for me; scripts do not have to be re-written and everything works. So I have time to research IPv6 and how to integrate it into my LAN later.


If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.