[SOLVED] WiFi Uplink Connection not working

On the router, run this:

wget -O - http://connectivitycheck.android.com

This is how Android devices confirm that they are connected to the Internet. The expected result is an Error 404. If any html text appears, you have a captive portal.

2 Likes

Ok, I don‘t know, why. But if I change the IP address to be assigned to the router in my dhcp server from 5.27 to something (anything not yet occupied) else, it‘s working.

There is no other device with this IP on the wifi (my APs list all connected devices), and the firewall on 192.168.5.1 is off for these tests (and doesn‘t have any entry for 5.27 anyhow)...

I don’t understand, but obviously the issue must be somewhere else. I‘ll just use a different IP and let it rest.

A big THANK YOU to everybody who helped to analyze this.

2 Likes

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik

For anybody who wondered (if anybody), the root issue here was an error in the ARP tables of the gateway for the 27 IP. After fixing the ARP table, the openwrt router also worked with the 27 IP.

Thanks again to everybody who helped in digging into this. Very much appreciated!!!

2 Likes

Pretty weird though, as the gateway was issuing this IP from its DHCP server.
Unless you had some static arp entry forgotten there

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.