[SOLVED] Wifi config for wan doesn't work when bridged

Hi,

So I have this /etc/config/network configuration file which has wan and wan_test interfaces :

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'wan'     
        option proto 'dhcp' 
                           
config interface 'wan_test' 
        option type 'bridge'
        option proto 'dhcp' 
        option name 'eth0.1'              
config device 'wan_test_dev'
        option name 'eth0.1'              
        option macaddr '80:1f:12:7e:14:46'
                                          
config switch                 
        option name 'rt305x'
        option reset '1'      
        option enable_vlan '1'
                              
config switch_vlan                 
        option device 'rt305x'
        option vlan '1'            
        option ports '0 1 2 3 4 6t'

And /etc/config/wireless file is configured in client mode as follows :

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wan'
        option mode 'sta'
        option ssid 'MY_HOTSPOT'
        option encryption 'psk2'
        option key 'B1yPSbxxZtUBveLx0oAsLTHQxesDg0EHXnYm'
        option macaddr '80:1f:12:7e:0a:09'

Modifying /etc/config/wireless,
When binding wlan0 to wan, I get an IP addr and it all works fine.
When binding wlan0 to wan_test, I can't connect to the network (no IP addr is attributed).

What am I doing wrong ?

Thanks.

An ordinary STA interface won't work in a bridge. This is because the standard does not support multiple MAC addresses on the STA side. The WDS mode does allow bridging a STA because it sends four MAC addresses instead of three. The AP must be WDS capable to use this mode.

4 Likes

Thanks @mk24

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.