[SOLVED] Why did the nlbwmon menu disappear?

Hello everybody...

I finally managed to complete the installation/configuration of my router... now, I believe that at least it is working as it should.

However, I noticed that the menu for accessing nlbwamon simply disappeared.
2024-06-03_19h53_34

Yes, it is installed and configured correctly, but I don't know why, it disappeared.

Is there any way to edit the json files and return it to normal, like before?
My files is here in /usr/share/luci/menu.d...

I already tried reinstalling just luci-app-nlbwmon, but it didn't work correctly. I also tried removing nlbwmon and that didn't work either...

Have you tried resetting browser cache/trying different browser you've never used to access OpenWrt WebUI?

Is the process running? Try htop -F nlbwmon

@stangri , yes, Yes, I tried in other browsers, I even tried using their anonymous tab...

Is running...

root@horus:~# service nlbwmon status
running
root@horus:~#


:face_holding_back_tears:

All looks correct to me. ¯\_(ツ)_/¯

Let’s see if the runtime gives any output: nlbw -c show -g mac,fam

Did you by any chance update any packages, not only install them?

Just a guess but you may be hitting https://github.com/openwrt/luci/issues/6422 (cause luci-app-nlbwmon defines a depends on nlbwmon), try running rm -f /tmp/luci-indexcache* and see if it magically appears after you logout and login again.

2 Likes

I didn´t Frolic...

I'm completely reconfiguring my router, reinstalling and reconfiguring each package until I'm finished...
The other day I realized that the nlbwmon menu had disappeared...
Is there any way to edit the menu entries and recreate this entry manually?

Unfortunately it didn't work...

I just ran the command and tested it in the incognito tab of Edge and Chrome...


I believe there must be some way to edit the menu manually and add the entry there again...

My router is all configured and working correctly...

@topsbr I'm not sure if it would be any better than the command @dannil suggested, but have you tried rebooting the router?

Failing that, I'd try installing/switching to a new theme, maybe that will trigger menu rebuild?

1 Like

Sorry for the delay friends...

I tried...

=> rm -f /tmp/luci-indexcache*, as suggested by @dannil and it doesn't work...

=> I restarted my router, as suggested by @stangri and it doesn't work... but after that, my IPV6 stop works :sweat_smile: :sweat:

I tried removing luci-app-nlbwmon and reinstalling and it doesn't work either...

Honestly, I don't know what could have caused this... I suspect that the problem started after installing mwan3, which I haven't even been able to stop and reconfigure it yet.

Anyway, I think that reinstalling the nlbwmon package should work as it would reset the controls back to Luci... or even, there should be some way to manually edit the menu and entries and add this entry manually back to the menu , but I don't have enough knowledge for that... I saw in some posts the possibility of removing the menus and I successfully applied it to my dumb-ap... but I haven't been able to add it yet.

Thank you all again

If you open luci-app-nlbwmon.json inside the menu.d folder in your first screenshot and it contains the admin/services/nlbw, admin/services/nlbw/display and many other entries this is enough to make it show up, this is how you register routes for a LuCI app. Since I assume it's correct (you can post it here otherwise, no secret information in it) that's why I suspected it was something with the cache cause those routes are indeed cached by LuCI.

Hello @dannil ...

The file is correct, see:

Presuming that problem is the cache of web browser, in anonymous tab of browser, It should work, right?

I tested access through other browsers and other computers / tablets and mobile phones and none of them work.

Yes it looks correct, thanks for verifying.

Not necessarily, the LuCI cache I asked you to delete is on the server side, not client, so it wouldn't work to just change browser/device on the client side as the menu rendering is done before it even hits the client. However, you posted earlier that you both tried the command and rebooted after running it as part of the suggestion by @stangri, so it should not be the cause then.

To clarify; run rm -f /tmp/luci-indexcache* and directly after reboot the device (physically if possible but poweroff in the same shell should be fine), doing it through LuCI will re-generate the server side cache, nullifying the deletion.

Hello everybody...

I followed the instructions and it still didn't work...
I quit.

How I did...

01 - Dodge the command rm -f /tmp/luci-indexcache* via ssh...
02 - I physically turned off the router and waited a few seconds before turning it back on...
03 - I reconnected and retested, without success...

Curious, but it doesn't work...

Soon I will run a backup and rebuild this router from scratch again.

Hello everybody...

Sorry for the long delay in returning to this topic - I had some health problems, so the router was stopped at home and my wife was using the operator's horrible router, which for commom users, fulfills the role of providing internet and nothing more... .

Well, I started rebuilding my router based on a tinypc and when reconfiguring the packages, I was analyzing case by case, where I found an error in the nlbwmon.conf file...

With the new nlbwmon working correctly, I saved its configuration file and then replaced it with the file I had in the backup and to my complete surprise, after restarting the nlbwmon service, it simply disappeared from the menu, as reported above...

When stopping the service and returning the original configuration file and restarting the service, the menu was available again.

So, here's a tip for friends to be careful with configurations made that can do these things, but the interesting thing is to note that, even though nlbwmon was not present in the Openwrt menu, it remained running all this time, collecting information and saving it on my hard disk.

Hugs to everyone and long live Openwrt!

The menu has a uci dependency on nlbwmon. If /etc/config/nlbwmon is unreadable (e.g. absent file, insufficient permissions or syntax errors) then the menu entry is hidden.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.