[SOLVED] Wget configuration

Hello all,
I want to setup wget to prefer ipv4.
I put a .wgetrc in the root home directory with

prefer_family = IPv4

to no effect.
Thanks for your help
Guy

which wget you are using?

The actual GNU wget that need to be installed separately?
/usr/bin/wget

Or just either busybox or uclient-fetch wget substitude apps?
/bin/wget
(neither of those use .wgetrc)

Likely you just need to install the proper wget package

LEDE:~ # which wget
/bin/wget

opkg install wget

LEDE:~ # which wget
/usr/bin/wget

and now it works :slight_smile: thanks!

But my initial problem was with the luci interface to opkg.
And it looks lik it is still using /bin/wget :frowning:

luci just uses opkg commands (and doesn't care about the underlying wget commands issued by opkg)

you might need to reboot your router to get everything straightened up.

And you may need to to check your /etc/profile that you surely have the current PATH correctly. (If you have sysupgraded from ancient versions, you might have non-standard path. But likely that is not the case as which gives you now the right wget)

root@OpenWrt:~# grep PATH /etc/profile
export PATH="/usr/sbin:/usr/bin:/sbin:/bin"

root@OpenWrt:~# env | grep PATH
PATH=/usr/sbin:/usr/bin:/sbin:/bin

Thanks a lot
reboot did it

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.