[SOLVED] Web GUI doesn't open after LAN adresss change

I had 18.06 working perfectly fine with SQM and Adblock until two days ago when I accidentally deleted the dhcp module configuration and I didn't have a backup
In a moment of panic I made a reset and did the configuration again from scratch but that didn't work for some reason (trust me i spent the entirety of yesterday troubleshooting it)
Now I tried 19.07 and I really like it's updates and new web GUI
But again for some reason whenever I change the LAN address to match my network my browsers just don't connect and get the error "Connection Refused"
Chrome and Firefox can't connect to it (Firefox does but if use the openwrt.lan address instead of the numeric one)
My only way inside the configuration right now is either SSH or Edge Browser

The connection is stable and other devices can connect normally
I tried reinstalling my browsers but that didn't help

Any advice will be greatly appreciated
Thanks in advance

Have you checked that you have installed/configured and started the uhttpd service?

netstat -nlp #check for port 80/443
service uhttpd restart

and then see if you can browse to it. Also check/clear browser cache in FF/Chromium

I'll second that, since OP says that Edge browser works.

yes I did, uhttpd is installed and running
and yes I also cleared the cache and flushed the dns several times


I uninstalled Firefox and manually removed all of its files and folders, which got it to work
I will try for chrome later because I need my accounts login credentials active for now

Thanks everyone

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).



Update 2
My fix was just manually deleting my browsers' profile/account/session data
However I do feel @trentmu's solution is a much better and more realistic to be other people's solution if they ever encounter such issue

Yes, that's an overkill.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.