[Solved] WD MyBook Live Duo / two disks

Thank you all!

I'm sorry, I have no physical access to my MBLD during my holiday, hopefully I can start testing in the coming days.

Just one question: will this patch be included in the final 18.06 release? I prefer using stable releases on my "production" devices.

That is the plan, yes:

Unless there are legitimate objections I expect them to slip in before the release of 18.06 proper.

1 Like

Everything is working smoothly with snapshot build so far... disks, partitions, raid, samba...

However, I cannot find the nfs-kernel-server package. Is there any specific reason for left it out?

Can I use the rc1/rc2 packages instead?

Edit: it's working perfectly with the rc2 package. :slight_smile:

Maybe a bit off topic but have you managed to use raid for the system partitions? (/dev/sda1 and /dev/sda2)
I kind of liked how the official firmware functioned in that aspect.

Speed on a fully initialized RAID 0:

root@NAS:/mnt/data# time dd if=/dev/zero of=tempfile bs=1M count=1024
1024+0 records in
1024+0 records out
real	0m 15.23s
user	0m 0.01s
sys	0m 12.63s

root@NAS:/mnt/data# time dd if=tempfile of=/dev/null bs=1M count=1024
1024+0 records in
1024+0 records out
real	0m 7.91s
user	0m 0.00s
sys	0m 6.82s

That's ~67 MB/s writing, ~130 MB/s reading. Out of curiosity:

a) the RAID is initialized, but is the ext4 filesystem too? Unless you specify -E lazy_itable_init=0,lazy_journal_init=0 when formatting, the drive will "lazy init" the inodes during regular operation for quite some time (you can see it blinking access even while not in use), and I believe that's why you are seeing slightly lower write performance than I did in my test. However, it could be the CPU overhead of RAID, too. Ultimately, drive performance is still limited by the CPU.

b) do you know/remember the performance with the original firmware?

Both of these are really not issues, though. I'm thrilled with the performance of my MBLs now.

I don't know... Is there any way to tell if the filesystem initialization is complete?

I never tested the pure disk performance this way, only through network. That was about 100 MB/s reading, 40-50 MB/s writing (on gigabit ethernet, but there were too many factors there).
I will do this test with the original firmware later today.

During the RAID rebuilding I saw speed well over 160 MB/s in /proc/mdstat. That's impressive.
Anyway, I'm happy with this throughput... :wink:

No, unfortunately the lazy initialization does not publish any stats to the system. But you can tell by the constant blips in drive activity. Anyway, it's not that horribly important.

Speed with factory firmware (and with some unnecessary service stopped, like access, avahi-daemon, netatalk, orion, etc.):

NAS:/DataVolume# time dd if=/dev/zero of=tempfile bs=1M count=1024
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 10.4665 s, 103 MB/s

real	0m10.507s
user	0m0.012s
sys		0m9.676s

NAS:/DataVolume# time dd if=tempfile of=/dev/null bs=1M count=1024
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 7.25067 s, 148 MB/s

real	0m7.257s
user	0m0.008s
sys		0m5.680s

For what it's worth, in real life usage it doesn't make too much of a difference whether you get 60, 70 or 80 MB/s from the disk. Samba will hit CPU limits at about 38 MB/s reading and 29 MB/s writing. I couldn't test it with my current setup, but I imagine rsync too will hit CPU rather than disk transfer limits.

At any rate, it's really nice to see that disk I/O is not the bottleneck on the device anymore.

As expected, the patch has been committed to 18.06 (and 17.01, presumably for another point release in the future.)

Also, somewhat related, another patch has been committed to master, unifying the Duo and Single images, there's already only one image built for both.

I reckon it's about time for a wiki entry.

1 Like

Could you please point me to the device wiki entry? I found the techdata pages only.

That's the point, there isn't one yet. :slight_smile:

Edit: Now there is. I'm filling in the basic stuff right now.

1 Like


Just installed 18.06.1 and noticed that it is missing packages for usb :frowning:
Anyone know which I should install? Should I report the problem somewhere? It used to work perfectly on 18.06

This may be a silly question, but are you absolutely positive you installed the image for the "Duo" variant? (I'm asking because in the past, I myself sometimes accidentally picked the wrong image, they are easy to mix up in the file list.)

Yes, I just verified with my download history.
I downloaded and flashed this one

I tried installing some packages and kernel modules manually but they don't seem to make a difference. The kernel log does not include any references to usb hubs etc.

I am willing to experiment but I don't know what else to do other than downgrade

In the commit history the only change that touched the APM821xx target was this fairly extensive one. I'm not nearly dev enough to judge whether this could have borked USB on the Duo. We should probably ping @chunkeey to get an educated opinion.

For the time being, I believe there is no harm in downgrading, and no immediate need to upgrade to 18.06.1 (since your MBL is unlikely to be an edge router directly connected to the internet.)

Thanks, I will leave it as is for a couple of days in case @chunkeey needs me to try anything or needs any logs etc to troubleshoot.

Also, I was under the impression that the two configurations (single and duo) would be unified. It is already unified in the snapshot branches. Do we know why this didn't happen in 18.06 and 18.06.1? Does it need to be accepted higher up?

At any rate, thank you for bringing up the issue.

As for the "unification", it's mostly a cosmetic fix. For all intents and purposes, the "unified" image is just the MBL Duo image that also works fine on the "Single". So I guess it wasn't very high up on any of the dev's priority list. I tried to poke a dev to get it cherry picked for 18.06.0, but it missed the deadline and was forgotten after.

You can look that up on the WebInterface/LuCI-landing/main page just after you login. It's the "model" entry should say "MyBook Live Duo" for 18.06.x . If it's just "MyBook Live" then: "There's the problem. The single Image does not have any usb support apart from usbip. The hardware is disabled and installing and loading the modules will do 'nothing'".

sysupgrade does not automatically reinstall all the packages you had manually installed with 18.06.0.
If you are looking for a "one-shot" sysupgrade that will include the packages you had, your best option is - I think - to go with the attended sysupgrade LuCI app (package: luci-app-attendedsysupgrade ) in the future (as of right now, the it's still a WIP)

However, 18.06.0 and 18.06.1 do come with the basic usb-storage + uas modules from the get go. And from what I have heard, they are working right out of the box. So can you please test a simple, but known-good usb-stick and see if a block device (/dev/sdc) appears in dmesg when you plug it in.

(my MyBook Duo is essentially bricked because of a faulty PSU. I still have it, but mostly as a piece on the shelf)