I want to reject switch of my ISP to save some cables - the switch is always hanging to them. ISP uses the switch to separate IPTV and internet. I consulted with ISP technicians and I was told that there is nothing complicated if my router is capable of this. The router - WR2543ND, firmware - 'lede-17.01.4-ar71xx-generic' from today. Untill yesterday I tried to make this bridge with OpenWRT, but unsuccesssfully. I read many posts and sites and understend what is "tagging" and how to eat it, but ther is not equal router settings out there in example posts...

Here is Switch menu of the router firmware:

default switch

May be I must try something like this:
Create VLAN-3: CPU, LAN 3 and LAN 4 - off, WAN - tagged, LAN 1 and LAN 2 - untagged.
WAN to be 'tagged' to VLAN-3 or must be 'untagged'?
I hope LAN 1 and LAN 2 to be for IPTV, LAN 3 and LAN 4 for home network (which is bridged with home WLAN in Interfaces).

Thank You for attention!

Do you have any more information about the requirements for the IPTV with respect to how it is supposed to work (tagged vs untagged VLANs, for example)?

Assuming that the switch you are removing is a simple/unmanaged switch, my guess would be that there are no VLAN tags required. If the IPTV is essentially just split off the WAN side of the router, you probably don't need to do much here -- a simple change to the VLAN assignments in the LEDE router should be all you need to do. You probably won't even need to create a new VLAN ID and you can keep everything untagged.

Based on your stated goal of LAN1 and LAN2 = IPTV, LAN3 and LAN 4 = home network, try the following:

In the VLAN1 row, change LAN1 and LAN2 to off.
Then in the VLAN2 row, make those same two ports untagged.
Save & Apply.

What this does is basically just makes LAN1 and LAN2 the equivalent of 'pass-through' (simple switching) of the WAN interface -- the data passing through doesn't hit the firewall or any other routing on your LEDE device. The other two ports will function normally as a LAN (home network).

Also, keep in mind that the LAN 'x' designations on the LEDE switch page may or may not correspond with the physical port labels on the router itself. A quick way to test this is to just turn off one port (off for both VLANs) -- this will cause the port to be 'disconnected' internally and you can easily associate the GUI with the physical markings.

It's working and quality of picture on tv is better!
Now LAN 1 and LAN 2 are in bridge with WAN port, just as psherman said.
There was a lagging (short stopping), when I watch missed shows on tv, but now this is solved too.

Thank You very much!

Here is working configuration on router switch:

working switch

Thank You again!