[Solved] Wan dhcp no internet


I have a netgear wndr3700v4 that has worked well with pppoe connected to an adsl modem in bridged mode.

I have just gotten hfc nbn(in Australia) installed. I changed the wan config to use dhcp instead of pppoe. The wan correctly picks up an ip address and default route, but I cannot access the internet.

Sometimes when applying interface changes ping works for about a second. There is also no interenet access directly from the router(after sshing in).

Any ideas on what is going wrong?


Does the device pick a public or a private IP address on the WAN interface?
If it is private, does it collide with the IP address on the LAN interface?

The router picks up a public ip, but can't access the internet. It is the same public ip that I get with my laptop plugged directly into the cable modem(internet works in this scenario).

What is interesting is that when I click 'CONNECT' on the wan interface from within luci, I have internet access for 9 seconds before it gets cut off.

What does LEDE do when the 'CONNECT' button is pressed?

AFAIK, the CONNECT button just drops the connection down, and then pulls it up again.

I cannot think of any reason why your setup should not work:

  1. Have you seen anything interesting in the logs?
  2. Does your laptop have any particular software or configuration?
  3. Perhaps your ISP has a restriction and only allow specific devices to connect?

A reboot of the cable modem fixed things...

Thanks for the suggestions eduperez.