[SOLVED] WAN connection on TL-WR810N not working

Hi all,

I am setting up an old TL-WR810N device to use a fiber internet connection from "Deutsche Glasfaser".
The WAN interface (eth0) is up and has a valid IP address from the fiber modem. (DHCP-client)
Login information is stored on the fiber modem, therefore I don't need PPPoE.
The routes and firewall rules are set to default values and should work as fas as I know.

Via wlan or eth1 interface I can't reach the gateway of the WAN interface or any IP address in the net (e.g. A traceroute tells me that the correct route to the WAN interface is used, but after that I get the message that the target net is unreachable.
What I can see are UDP connections to the DNS servers of the provider.

Can you help me checking what I have missed or configured wrong?
I am using OpenWrt 18.06.2 via LuCI.

In general, when I connect a PC directly to the fiber modem, the internet connection is working just fine. Yes - I know that I won't be able to use the full bandwith of the fiber connection with this device (TL-WR810N).

Could you try to ping an internet service ( for example from the TL-WR810N.

If its working i think there is an issue with the firewall configuration.

Is the eth0 port the standart wan port?

With the diagnostics page from LuCI, I also get 100% package loss (ping) or a "!H" in the traceroute for

eth0 is printed on the device as being the LAN/WAN port.
eth1 and wlan are bridged and using the DHCP server on the TL-WR810N.

Please post here the output of the following command, all in one line
cat /etc/config/network; cat /etc/config/firewall; cat /etc/config/wireless ; cat /etc/config/dhcp ; ip -4 addr ; ip -4 ro ; ip -4 ru

Hi all,

sorry for the delay. I had several phone calls with the provider and it turned out that I have to set a VLAN-ID to the WAN port. With that setting everything works just fine.

Therefore the topic can be closed.
Thanks to all trying to help me out!

@freakfeuer, welcome to the community!

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.