[solved] WAN connection not working after power outage

After a power outage, I lost my wan connection on my router running OpenWRT. Here are the system details:

  • Model: Buffalo WZR-HP-G300NH
  • Architecture: Atheros AR9132 rev 2
  • Firmware Version: OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)
  • Kernel Version: 4.9.152

I confirmed that I could connect to the Internet using my cable modem if I connect directly to the Ethernet port on the modem.

The wan interface (device eth1) doesn't show any transmission or receiving. Is there some way I can check the status of the network adapter itself?

I am able to access the device's admin interface over WiFi and also SSH into the device.

The answer depends a bit on the reason of the power outage, e.g. a lightning strike nearby might have damaged the WAN port, similar results could stem from overvoltage, brownouts, etc.

Assuming electrical damage is not part of the problem, another potential cause of problems might be file (configuration-) corruption on the router, especially if your power didn't come back up cleanly (but 'stuttered', resulting in multiple partial boots). If you don't feel confident checking for that, I'd suggest to export a configuration backup (tarball, you can also check this manually for obvious corruption) and then to re-flash OpenWrt 18.06.2 without keeping settings(!), I'd at least start with a fresh configuration (no config restore either), in order to check if your device is working now; especially with cable and its tendency to lock onto MAC addresses, it might help to reboot both modem and router at the same time.

@slh, thanks for the suggestion. I was worried about electrical damage too.

Ultimately, I didn't even have to re-flash.

I reset the configurations to the defaults. After that I power cycled the cable modem and the interface was able to connect.

I had previously tried power cycling the cable model first, then the router, which didn't restore connectivity on the WAN interface.

Just as a reference for others that might be encountering similar problems, the LAN LED on my cable modem wasn't lighting up. On my router, the WAN port LED didn't light up (though it lights up when the configuration gets updated, along with the switch LEDs) and even now that the connection is restored, the WAN LED still doesn't light to indicate connectivity.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.