[Solved] Vpnc: package is missing?


it seems as if the package vpnc is not available. It's not in the package list on the router. It's not in the package list on https://openwrt.org/packages/index/network---vpn.

Any help appreciated.

Kind regards

https://openwrt.org/packages/table/start?dataflt[Name_pkg-dependencies*~]=vpnc shows it exists in the index, at least for some architectures.

It is being maintained:

openwrt/feeds/packages$ git log net/vpnc
commit 494ce7118
Author: Rosen Penev <redacted>
Date:   Sat Jan 5 23:34:20 2019 -0800

    vpnc: Updated deprecated patch to include OpenSSL 1.1
    Patch was only for 1.0.2. This adds 1.1 support.
    Signed-off-by: Rosen Penev <redacted>

Have you run opkg update or used its LuCI equivalent?


The vpnc package is missing, possibly due to some kind of compilation error.

Yes, I tried opkp update and LuCI.
As it is clear now, that the package is missing for [arm_cortex-a9_vfpv3], what is my best chance to get it for 18.06.2?

Seems to be because the 18.06 buildbot buildslaves do not have "svn" installed, so the sources can not be downloaded:


Checking out files from the svn repository...
/bin/sh: 1: svn: not found
/bin/sh: 1: svn: not found
Makefile:94: recipe for target '/builder/arm_cortex-a9_vfpv3/build/sdk/dl/vpnc-0.5.3.r550.tar.gz' failed
make[3]: *** [/builder/arm_cortex-a9_vfpv3/build/sdk/dl/vpnc-0.5.3.r550.tar.gz] Error 127
time: package/feeds/packages/vpnc/compile#0.12#0.01#0.77

any possibility to get svn into the buildslaves ?
(I think that it is missing from some of the master slaves and apparently from the 18.06 slaves)


so now we know it is missing (and probably why). How do I get this package for my 3200acm and 18.06.2? Is it downloadable somewhere or do I have to wait until 18.06.3?

Quickest way is that you setup an OpenWrt buildroot (e.g. in a virtualbox Ubuntu) and compile vpnc by yourself. (And install svn to your buildroot before starting the build).

1 Like

The packages are now available.
Thank u very much.

1 Like