[SOLVED] VLAN-Trunking between WRT1200AC and TP-SG108E

Hello everyone,
I just recently found my way to LEDE as I purchased a WRT1200AC router. So far everything concerning LEDE is working very well except trunking between 2 devices.
Idea was to create 2 VLANs, both of wich were connected to 2 WiFis and since not every cable in my flat ends in the same place: another switch.
Since the TP-SG108E is a so called "smart switch" wich basically means it can do 802.1Q I decided to leave it with stock firmware and got LEDE on the Linksys. Now I have setup VLAN, connected the tagged ports for trunking but for some reason I can connect to the switch when physically connected to the router but not to the router when physically connected to the switch.
I have attached my configs below. Does someone have an idea where I misconfigured? I hope my description is understandable.

Thanks!

Both devices are connected permanently on each port 1.
LEDE Device:
Network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd66:cccb:2e1f::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.0.5.1'
	option _orig_ifname 'eth0.1 wlan0 wlan1'
	option _orig_bridge 'true'
	option ifname 'eth0.1 eth0.5'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '1 3t 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '7'
	option ports '0 3t 5t'

config interface 'badlands'
	option proto 'static'
	option ifname 'eth0.7'
	option type 'bridge'
	option ipaddr '10.0.7.1'
	option netmask '255.255.255.0'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '5'
	option ports '2 3t 5t'

Firewall:

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option name 'badlands'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option network 'badlands'
	option family 'ipv4'

config forwarding
	option dest 'wan'
	option src 'badlands'

config rule
	option proto 'tcp'
	option dest_port '80'
	option name 'Webinterface'
	option src 'badlands'
	option dest_ip '10.0.7.1'
	option target 'REJECT'

config rule
	option enabled '1'
	option proto 'tcp'
	option dest_port '22'
	option name 'SSH'
	option src 'badlands'
	option dest_ip '10.0.7.1'
	option target 'REJECT'

TP-Link Switch:
(The VLAN-Config is a little crappy here, but in the lower part of the first picture you can see, that the same numbers are used as in LEDE. VLAN1 on port 1,2; VLAN5 on port 3-5; VLAN7 on port 6-8.
VLAN-1

Any help is greatly appreciated.

And since new users only can put one image in a post here is the second:
VLAN-2

And further since I forgot: The TP-Link is responding to 10.0.5.2 from the Linksys.

I couldn't do trunk with full distros on that crappy switch, did you managed to do it with anything ? I only needed port isolation so I used the option from gui for that

Yep actually it is working now! A reset and a reconfiguration of the switch with the exact same settings did the trick.