[Solved] VLAN between Wifi and Lan Archer C7 v5


I try to configure an OpenWrt as AP in my network.
Wrt is connected to a managed switch.
I have 4 Vlans defined


The managed switch acts a DHCP.
On the Wrt I have two Wifis
IOT and
IOT is connected to VLan 20
Net to Vlan 180.
Asignement works perfectly.
I connect to IOT Wifi and obtain an IP assigned from the IOT IP Pool and can surf and do everything.
For Net Wifi it is the same, it works as designed.

I only have eth.1 (Lan) connected to the managed Switch with a cable.
And I do VLan tagging.
As described above, it works.
But, I have a BananaPi connected to Lan2 .
I enabked tagging for Lan2, too but the Banana does not get a connection to the VLan.
What am I doing wrong?
thank you

Did you enable tagging on BananaPi as well?
If yes, post the configuration from OpenWrt.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
swconfig dev switch0 show
1 Like

To connect a regular Ethernet device to one VLAN, make its switch port untagged in that VLAN and off in all the other ones. The device will receive untagged packets so it can participate in one network. This is also known as an access port.

To send more than one VLAN over an Ethernet cable to another device, make the port tagged in the VLANs you want (and the others off-- don't set any untagged). The device at the other end needs to be configured with matching VLAN numbers. This is also known as a trunk port.

thanks for your reply.
The Banana is not configured to tag VLAN 20.
I thought the Wrt will tag for the Banana.
Can't i put LAN 2 in a VLan like I did with the Wifi?

Another option could be to set the PVlan on the managed switch to 20, so that every other untagged frame get's tagged as 20, but that doesn't work either.
Thank you

There is some misunderstanding on how tagging works. OpenWrt can and will tag an ethernet frame. But if you tag it, then the device on the other end (Bananapi in your case) should be able to receive tagged frames. If it cannot , then you either need to send untagged frames and assign the ones you receive to vlan2, or use and intermediate managed switch.

Hi trendy,

thanks for your reply.
With the information from the othr posts I finaly achieved to get exactly what I wanted so far.

I sat he trunk Port (Port 13) on the managed switch to:

VLAN 1: tagged (all other Ports still untagged in VLAN 1)
VLAN 20: tagged
VLAN 180: tagged
These Vlans enter the managed switchport 13

The Trunkport on WRT (LAN1)
is set to:
VLAN 1: tagged
VLAN 2: off
VLAN 20: tagged
VLAN 180: tagged

The LAN Port on Wrt (LAN2) which is not physically connected to the managed switch.

VLAN 1: tagged
VLAN 2: Off
VLAN 20: untagged
VLAN 180: Off

This works for now.
I can Ping from the management VLAN to the devices inside
all VLANs (1,20,180)
and I can Ping from all VLANS (20,180) into the others (1,20,180)
Okay, they arent relay separated, like a firewall would do, but the obtain the right IP from the correspondig IP Pool arranged on the managed switch.
Additionally all VLANS (except VLAN 2) reach the Internet.

Next step is to turn of an DHCP Srv inside VLAN 1 and let the managed Switch serve these adresses to. I guess this will mess up the config :wink:

Thank you

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.