[Solved] VLAN 10 Tagging WAN port Linksys WRT1200AC

Hi There

My ISP requires me to tag my WAN port with VLAN 10 first then run PPPOE over the top.

See fibre settings here https://www.spark.co.nz/help/internet/set-up/broadband-settings-for-third-party-modems/

Here are my configs so far but it is not working:

root@LEDE:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfd:7a55:f2c1::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '172.16.13.254'

config interface 'wan'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option ifname 'eth1.10'
	option proto 'pppoe'
	option username 'user@spark.co.nz'
	option password 'password'
	option ipv6 'auto'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'

I know that this router supports this as it works fine under the stock firmware:

The first thing I need to do is tag the traffic VLAN 10 and then on VLAN 10 run the PPPOE service.

I am a little new to VLAN's so not sure what the difference is between VLAN 10 tagged and VLAN 10 untagged.

Help is appreciated.

Cheers
PD

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '10'
option ports '4t 6t'

After PPOE configuration

In this device, switch ports 0-3 are connected to LAN, port 4 is WAN, port 5 is eth0, and port 6 is eth1. As there are separate CPU ports, we do not need to tag those. Thus, the LAN part is:

config switch_vlan
option device 'switch0’
option vlan '1’
option ports ‘0 1 2 3 5’

And we configure it with "option ifname 'eth0'".

Now, for the WAN part we need to tag on the outside, as per ISP requests, but we do not need to tag it on the inside, as it is connected to a separate CPU port. Thus, the WAN part is:

config switch_vlan
option device 'switch0’
option vlan '2’
option vid '10'
option ports ‘4t 6’

And we configure it with "option ifname 'eth1'".

Thanks for getting back to me. Will give these a try tomorrow.

What is the difference between the two solutions?

Also is it possible to configure this by Luci web gui.

No problems if it can’t but just for my own reference in the future. I’ve always been a dd-wrt person so first time into the openwrt/lede world.

Fun!

Doing what @eduperez said, the only thing you need to change from the regular default configuration is in the switch. Change the wan's VLAN from 2 to 10 and make it tagged on the external port. You can do this on the switch page in LuCI. The switch hardware will add and remove VLAN 10 tags by hardware as the packets go to the Ethernet cable. The CPU will see an untagged pppoe connection.

Thanks for your help. I was able to get this configuration humming along.

Happy Holidays.

PDANZ