[SOLVED] Username/Password doesn't work on 6984-fa0275b


I recently installed 6984-fa0275b fresh on a Meraki MX60W. After booting, I am unable to login to LuCI or SSH except on the first boot. Even if a password is set or unset, dropbear refuses connections on tcp/22, and LuCI states invalid username and password while displaying the no password set dialogue!

If I set the password on first boot, I'm still unable to login.

Any ideas?

"Feels like" /overlay isn't being preserved across boots.

Not sure...but configs must be there, because the password is there (if I set one and reboot, the no password configured dialogue disappears)...I just can't can't login via LuCI or SSH.

Also remember though, this occurrs even when I leave the password unset. I tend to config a router first, then assign a password, this is how I discovered the issue (I made a config change, rebooted, and could no longer login).

I should probably note, I sysupgraded another MX60W as well, I was able to login via LuCI and SSH after rebooting that device, but it also had issues (no LAN to WAN).

More information is included in the "No LAN to WAN after sysupgrade to 6984-fa0275b" thread - linked above.

I took a meal break and returned.

I did the following on serial:

  • firstboot
  • reboot

When it restarted, I immediately logged in and saved a password and rebooted. Upon reboot, it worked, I could login to LuCI with the password!!!

  • I set the device back to factory defaults and rebooted
  • I logged in and did not set a password
  • I made the same settings changes to test (turned off rebind protection)
  • I rebooted
  • I was able to login with no password

My issue with the new device...albeit quirky...is fine.

I believe I performed these steps multiple times before posting...just odd.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.