[Solved] USB-to-Ethernet adapter for Android not connecting

I'm trying to connect an Android phone to my PCEngines APU4 router with a usb-to-ethernet adapter. I have three adapters that worked fine with OpenWRT on a Netgear router. One of them is a PinePhone Pro ethernet dock, another a TP-Link UE300C, and a UOEOS adapter. All three adapters have the Realtek RTL8153 chip according to "lsusb" in a terminal window. I installed kmod-usb-net-rtl8150, kmod-usb-net-rtl8152, and r8152-firmware. I also went to Network -> Interfaces -> Devices -> br-lan -> Configure -> Bridge ports and have eth0, eth1, eth2, and eth3 selected. I rebooted. My Ubuntu laptop connects fine on all four router ports and internet is good. My ethernet adapters are not working, though. I saw a brief led light flicker on one of the router ports my TP-Link was attached to and the TP-Link flickered briefly like it was communicating. Then it stopped and there were no results on the other adapters at all. Is there something else I can try?

While it might be obvious to you, what you want to accomplish - your description doesn't really tell us.

  • so, you have an APU4 running OpenWrt, it gives you four ethernet ports to play with - presumably your USB-to-ethernet cards aren't needed there (as you already have plenty of ports on that device).
  • I don't think your "Netgear router" is of any relevance to this question, as it's not part of the intended setup (at least not in the data path required here).
  • your notebook, presumably with its onboard ethernet port, seems to confirm that the APU4d? is working/ configured correctly.
  • you also seem to have checked the functionality of your three usb-to-ethernet cards, albeit not quite conclusively how.

Based on the topic, I assume that you want to connect your android phone via one of those three usb-to-ethernet cards with your router in a wired fashion, which is… kind of …unexpected…, as one would normally prefer wireless access in that case (be it via mini-PCIe WLAN cards plugged into the APU4d? or using a dedicated/ external AP (like the "Netgear router" you mentioned).

So if the topology you envision is:

[PHONE, USB3] <--> [USB-C, TP-Link UE300C, ethernet] <--> [ethernet, APU4]

I don't really see how OpenWrt is involved in this.

As far as the APU4/ OpenWrt are concerned, you are just another ethernet user - the preinstalled igb driver will handle that.

As far as the TP-Link UE300C is concerned, it's the phone you have to teach about it - which is not running OpenWrt for rather obvious reasons. In other words you need to ask in an Android venue about supported usb-to-ethernet cards and how to set it up. kmod-usb-net-rtl8150/ kmod-usb-net-rtl8152 would be OpenWrt packages which won't help you on Android (but recent rtl8153 chipsets might require a linux kernel newer than that found on most android devices, so the older the adapter, probably the better your chances).

I'm using my APU4 as a client and have just a 2.4 wifi card in it. I use it to connect to a public wifi access point. I connect all my devices to the router. My cellphone is a Pixel 6a with Android 13 and the wifi is not good on it. I also cannot get a cell signal because I am in an area with poor cell coverage. OpenWRT was installed on my old Netgear router to test the ethernet-to-usb adapters and they worked fine on that setup. I have connected the Pixel to the Netgear router with each ethernet adapter with OpenWRT installed on the router and they tested good. I never installed any drivers on the Pixel. I never had to teach the phone anything. I communicate with the outside world using a VoIP app on the Pixel and that has worked fine in the past using my old OpenWRT router setup. The goal in the future for the APU4 is to set up a cell modem with an antenna on a tall tower.

I am wanting to know if I missed anything in the basic setup with the APU4 ethernet ports using OpenWRT as mentioned above. My desired setup worked with OpenWRT already on the old router. OpenWRT on my APU4 looks just like it did on the Netgear. Thanks for your time.

I never have problems with ethernet cables and mine are new, but I had a problem with this ethernet cable on my project. I replaced it with another new cable and my ethernet-to-usb adapter sprang to life. I had the package kmod-usb-net-rtl8152 installed already so it's all working fine now. Thanks for the reply.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.