[Solved] USB Storage problem with OpenWRT 18.06 on Alfa AP121U

UPDATE: Upgrading to SNAPSHOT, r8021-9e58c20 solved the problem
Earlier today, I had Barrier Breaker installed on my AP121U, and I had USB storage working with no problems. I then upgraded to 18.06. Everything seemed to go well, and all the other functions of the Access Point are working as expected, but I lost the ability to use my USB storage.

I am using the exact same USB flash disk (formatted with vfat) that I was using before in Barrier Breaker.

Here are the USB drivers installed:

# opkg list-installed | grep usb
kmod-usb-core - 4.9.120-1
kmod-usb-ehci - 4.9.120-1
kmod-usb-storage - 4.9.120-1
kmod-usb-storage-uas - 4.9.120-1
kmod-usb-uhci - 4.9.120-1
kmod-usb2 - 4.9.120-1
kmod-usb3 - 4.9.120-1
libusb-1.0 - 1.0.22-1
usbutils - 007-7

Here are the file system modules installed:

# opkg list-installed | grep fs
e2fsprogs - 1.44.1-1
fstools - 2018-04-16-e2436836-1
kmod-fs-hfs - 4.9.120-1
kmod-fs-msdos - 4.9.120-1
kmod-fs-ntfs - 4.9.120-1
kmod-fs-vfat - 4.9.120-1
libext2fs - 1.44.1-1

When I lsusb, I can only see the root hub, not the Mass Storage device (previously, I could see the Mass Storage device under the hub).

# lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M

Here are the dmesg messages including usb:

# dmesg | grep usb
[    4.580938] usbcore: registered new interface driver usbfs
[    4.585099] usbcore: registered new interface driver hub
[    4.590493] usbcore: registered new device driver usb
[    9.547768] usbcore: registered new interface driver usb-storage
[    9.560986] usbcore: registered new interface driver uas

And I cannot see any devices starting with sd:

# ls -l /dev/sd*
ls: /dev/sd*: No such file or directory

I have the same problem on my ea3500 with the 18.06 builds (no /sd* device is ever found/present when using my ntfs drive), I've seen @z0rk mention using extroot on the ea3500, so maybe it's just a problem with ntfs. I haven't found a solution for the 18.06 builds, but LEDE 17.01.6 works fine with my ntfs drive on my ea3500 if you'd like to give that a try, it was just released September 3rd, so it's a brand new build with I'm sure a lot of fixes since Barrier Breaker.

Thank you, @mike. I will try LEDE 17.01.6.

I forgot to mention that I use my own build based off snapshot and it works fine with ntfs, so you might try a snapshot also (it has the newer kernel) if you don't mind installing Luci.

@Seattle Please edit your original post, putting all code, config, and log output within code boxes

Do you have block-mount installed?

  • opkg update && opkg install block-mount

Thank you @JW0914. The code blocks are surrounded by sets of three backticks now. Looks better.

Yes, I do have block-mount installed. I appreciate you mentioning it.

I now have OpenWrt SNAPSHOT, r8021-9e58c20 installed.

Before installing any user packages, this is how I found it on installation:

root@OpenWrt:~# opkg list-installed | grep usb
kmod-usb-core - 4.9.125-1
kmod-usb-ehci - 4.9.125-1
kmod-usb-ledtrig-usbport - 4.9.125-1
kmod-usb2 - 4.9.125-1
root@OpenWrt:~# opkg list-installed | grep block
root@OpenWrt:~# opkg list-installed | grep fs
fstools - 2018-05-23-dd02dad3-1
root@OpenWrt:~# lsusb -t
-ash: lsusb: not found
root@OpenWrt:~# dmesg | grep usb
[    4.765127] usbcore: registered new interface driver usbfs
[    4.769273] usbcore: registered new interface driver hub
[    4.774709] usbcore: registered new device driver usb
[    5.566953] usb 1-1: new high-speed USB device number 2 using ehci-platform

I then updated opkg lists and installed the following modules:

  1. kmod-usb-storage (which automatically installed kmod-scsi-core)

  2. usbutils (which automatically installed libusb-1.0 and librt)

  3. kmod-fs-vfat (which automatically installed kmod-nls-cp437, kmod-nls-iso8859-1, kmod-nls-utf8)

  4. block-mount (which reported: this file has been obsoleted, please call "/sbin/block mount" directly) - perhaps this isn't necessary.

I then rebooted the device, and checked for a block device at /dev/sda:

 OpenWrt SNAPSHOT, r8021-9e58c20
root@OpenWrt:~# ls -l /dev/sd*
brw-------    1 root     root        8,   0 Jan  1  1970 /dev/sda
brw-------    1 root     root        8,   1 Jan  1  1970 /dev/sda1

This worked! Problem solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.