[Solved] USB-serial converter: /dev/ttyUSB0 doesn't show up, how to load the kernel modules

Hi there,

I have a openWRT 22.03 running on a Raspberry Pi 3B. I want to use a USB-serial converter, but I can't get it to show up as a device (/dev/ttyUSB0).

Information about the USB-serial converter I am using (from dmesg):

[  662.967317] usb 1-1.4: USB disconnect, device number 4
[  664.288770] usb 1-1.4: new full-speed USB device number 5 using dwc_otg
[  664.443374] usb 1-1.4: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[  664.456875] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  664.466988] usb 1-1.4: Product: UC232R
[  664.473383] usb 1-1.4: Manufacturer: FTDI
[  664.480032] usb 1-1.4: SerialNumber: FTQ86WJV

I assumed that there is some package missing. Thus I compiled and installed kmod-usb-serial and kmod-usb-serial-ftdi (plus a bunch of others). I rebootet, but still the same problem. I wanted to load the module with modprobe (I thought it shouldn't be needed?, but they also don't appear in /etc/modules-boot.d/, so I thought maybe it's needed). But I always get that error

root@OpenWrt:~# modprobe usb-serial
invalid endianess: 0
failed to load the .modinfo section from /lib/modules/5.10.161/snd-soc-dionaudio-loco.ko
invalid endianess: 0
failed to load the .modinfo section from /lib/modules/5.10.161/snd-soc-pcm5102a.ko

If somebody could tell me what I am doing wrong? In both, using modprobe or maybe the problem (USB-serial converter not usable), has another solution? When I did my research the threads I saw nearly always hinted to some missing module problems.


Why did you compile them? Are you running a self-compiled OpenWrt image on your Pi? On a stock image, you should be able to install the modules using opkg.

1 Like

Well, after copying them on the device, I installed them with opkg :wink:
But yes, the image itself is also self-compiled.

Yes, you need kmod-usb-serial-ftdi and you may need to modprobe it.

Thanks, the problem is that I get this 'invalid endianess and failed to load the .modinfo section' error, shown above. Same output for modprobe usb-serial-ftdi.
It seems that in these two .ko files there is no content. Not sure why and how to solve that.
I think it came from somewhere during installation of kernel packages, since I just started to install a lot of them... yeah not a super smart idea.
Now I made a new SD card and just installed the needed kernel modules, at least the ones I need til now. And now it works fine.

So I guess even though I didn't find the problem to fix the original problem, it works for me, that probably won't help anybody else, but still thank you.