[Solved] USB NIC driver ax88179 is updated. The current version is AX88179_178A_LINUX_DRIVER_v1.19.0

USB NIC driver ax88179 is updated. The current version is AX88179_178A_LINUX_DRIVER_v1.19.0

The openwrt build is still a low version. When can I synchronize updates?

Try it if you need it.

Which bug fix or enhancement in the upstream Linux version is missing?


Why do you think that the update is missing? The last meaningful commit on Linux master for drivers/net/usb/ax88179_178a.c is on stable/linux-4.14.y

commit a0fc06335530
Author: Florian Fainelli <redacted>
Date:   Fri Sep 28 16:18:51 2018 -0700

    ax88179_178a: Check for supported Wake-on-LAN modes

The only commit following is related to SPDX license identifiers.

I now use two ax88179 ones as lan ones as wan. When I unplug the network cable from lan for a while, there is no reaction after re-plugging. Both wan and lan have nothing to do with this. The system will report an error. I think it is a driver problem.

[  379.659621] ax88179_178a 1-1.7:1.0 eth1: Failed to read reg index 0x0004: -110
[  403.011271] ------------[ cut here ]------------
[  403.016655] WARNING: CPU: 0 PID: 0 at net/sched/sch_generic.c:320 dev_watchdog+0x16c/0x268
[  403.026579] NETDEV WATCHDOG: eth0 (ax88179_178a): transmit queue 0 timed out
[  403.034626] Modules linked in: rtl8192cu rtl8192c_common rtl_usb rt2800usb rt2800lib qcserial option ipw brcmfmac usb_wwan usb_serial_simple ti_usb_3410_5052 sierra rtlwifi rtl8xxxu rt2x00usb rt2x00lib pppoe ppp_async pl2303 oti6858 nf_nat_pptp nf_conntrack_pptp mt7601u mos7720 mmc_spi mct_u232 mac80211 keyspan iptable_nat ipt_REJECT ipt_MASQUERADE garmin_gps ftdi_sio ebtable_nat ebtable_filter ebtable_broute cypress_m8 cp210x ch341 cfg80211 cdc_mbim belkin_sa bas_gigaset ark3116 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_socket xt_recent xt_quota xt_pkttype xt_owner xt_ndpi xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_iface xt_hl xt_helper xt_hashlimit xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_condition xt_comment xt_addrtype xt_TRACE xt_TPROXY xt_TCPMSS
[  403.118246]  xt_REDIRECT xt_LOG xt_IPMARK xt_HL xt_FLOWOFFLOAD xt_DSCP xt_CT xt_CLASSIFY xt_ACCOUNT visor usbserial usbhid usb_gigaset ts_fsm ts_bm sr9700 sierra_net ser_gigaset rtl8150 rndis_host r8712u r8152 qmi_wwan pppox ppp_generic pegasus of_mmc_spi nf_socket_ipv6 nf_socket_ipv4 nf_reject_ipv4 nf_nat_tftp nf_nat_snmp_basic nf_nat_sip nf_nat_redirect nf_nat_proto_gre nf_nat_masquerade_ipv4 nf_nat_irc nf_conntrack_ipv4 nf_nat_ipv4 nf_nat_h323 nf_nat_ftp nf_nat_amanda nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv4 nf_conntrack_tftp nf_conntrack_snmp nf_conntrack_sip nf_conntrack_rtcache nf_conntrack_proto_gre nf_conntrack_netlink nf_conntrack_irc nf_conntrack_h323 nf_conntrack_ftp nf_conntrack_broadcast ts_kmp nf_conntrack_amanda mcs7830 macvlan kaweth kalmia iptable_raw iptable_mangle
[  403.206745]  iptable_filter ipt_ECN ipheth ip6table_raw ip_tables huawei_cdc_ncm hso hid_generic gigaset ezusb ethoc ebtables ebt_vlan ebt_stp ebt_redirect ebt_pkttype ebt_mark_m ebt_mark ebt_limit ebt_among ebt_802_3 dm9601 crc7 crc_itu_t crc_ccitt compat_xtables compat cdc_wdm cdc_subset cdc_ncm cdc_ether cdc_eem cdc_acm brcmutil ax88179_178a asix arptable_filter arpt_mangle arp_tables sch_cake sch_teql sch_sfq sch_red sch_prio sch_pie sch_multiq sch_mqprio sch_gred sch_fq sch_dsmark sch_codel em_text em_nbyte em_meta em_cmp cls_flower act_vlan act_simple act_police act_pedit act_ipt act_gact act_csum sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred snd_bcm2835 hid evdev i2c_gpio i2c_algo_bit i2c_dev i2c_core
[  403.295642]  spi_ks8995 xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6t_NPT ip6t_MASQUERADE nf_nat_masquerade_ipv6 nf_nat nf_conntrack nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 isdn_bsdcomp dss1_divert isdn slhc ifb dm9000 sit sctp libcrc32c tunnel4 ip_tunnel veth tun snd_rawmidi snd_seq_device snd_pcm_oss snd_pcm_dmaengine snd_pcm snd_timer snd_mixer_oss snd_hwdep snd_compress snd soundcore mISDN_dsp l1oip mISDN_core
[  403.384611]  nls_utf8 sha256_generic seqiv jitterentropy_rng drbg md5 hmac ghash_generic gf128mul gcm ctr nls_iso8859_1 nls_cp437 xhci_plat_hcd xhci_hcd ehci_platform ehci_hcd gpio_button_hotplug ptp broadcom bcm_phy_lib pps_core
[  403.410625] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.14.123 #0
[  403.418573] Hardware name: BCM2835
[  403.423782] [<8010f78c>] (unwind_backtrace) from [<8010af58>] (show_stack+0x10/0x14)
[  403.435116] [<8010af58>] (show_stack) from [<805d21b0>] (dump_stack+0x98/0xb8)
[  403.444183] [<805d21b0>] (dump_stack) from [<80117fe8>] (__warn+0xe4/0x100)
[  403.452946] [<80117fe8>] (__warn) from [<8011803c>] (warn_slowpath_fmt+0x38/0x48)
[  403.463913] [<8011803c>] (warn_slowpath_fmt) from [<804dfdec>] (dev_watchdog+0x16c/0x268)
[  403.475578] [<804dfdec>] (dev_watchdog) from [<8016947c>] (call_timer_fn.constprop.6+0x28/0x94)
[  403.487758] [<8016947c>] (call_timer_fn.constprop.6) from [<801697c4>] (run_timer_softirq+0x1c0/0x44c)
[  403.500558] [<801697c4>] (run_timer_softirq) from [<80101570>] (__do_softirq+0xe0/0x240)
[  403.512134] [<80101570>] (__do_softirq) from [<8011d01c>] (irq_exit+0xd4/0x138)
[  403.521229] [<8011d01c>] (irq_exit) from [<80159080>] (__handle_domain_irq+0x9c/0xac)
[  403.532500] [<80159080>] (__handle_domain_irq) from [<8010bb0c>] (__irq_svc+0x6c/0x90)
[  403.543875] [<8010bb0c>] (__irq_svc) from [<801085d4>] (arch_cpu_idle+0x34/0x38)
[  403.554797] [<801085d4>] (arch_cpu_idle) from [<8014e0e4>] (do_idle+0xe0/0x1e0)
[  403.563918] [<8014e0e4>] (do_idle) from [<8014e440>] (cpu_startup_entry+0x18/0x1c)
[  403.575025] [<8014e440>] (cpu_startup_entry) from [<80800c20>] (start_kernel+0x358/0x364)
[  403.586838] ---[ end trace 632c398b69cbb90d ]---

I could find no OpenWrt patches for the driver, so it appears to be an upstream (Linux) problem.

I don't see anything "interesting" on Patchwork for the ax88179.

linux-netdev mailing list and archives would probably be where this might already be known, or resolutions being discussed. http://vger.kernel.org/vger-lists.html

in a hurry. This will cause my router to not work properly. Once the lan cable is unplugged or the computer is hibernating. Both wan and lan will stop working. I don't know how to solve this problem.
But see https://github.com/raspberrypi/linux/pull/2999/files#diff-f2b04890e4605b9554cc77093cfc9e2a
With https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/drivers/net/usb/ax88179_178a.c?h=linux-4.14.y&id=95ff88688781db2f64042e69bd499e518bbb36e5
Much like my question, especially the problem of binding failure below.
Very similar to my error log.
But I don't know how to apply it to openwrt.

You’ll need to patch it in, apparently for the Broadcom target as it is not generic in nature, as I read it. Instructions for “working with patches” and “quilt” are on OpenWrt.org (on my phone here or would link them for you).

The second patch is ancient, by kernel standards, and appears to already be in Linux stable.

This patch is against vanilla 3.17

thank you very much. But I still apply the above.

Here's the page on patches and quilt:

Thank you very much for your answer. I have solved the problem now.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.