[Solved]UQMI won't connect with Private APN

Hey Folks,

I have a Problem with the QMI protocol.

I bought a private ip from my ISP and can't connect with the private APN, only the dynamic IP APN works.

With ModemManager the connection to my Private APN works as expected, so no fault on ISP side.

I googled a little bit and found out that I'm not the only one having problems to connect to Private APN's and everyone who has problems with it, has an APN with two "."(dots) in the APN.

  1. Is that a bug?
  2. How to troubleshoot this?

Please let me know which logs or output from CLI you need.

However I only tried connecting through LUCI because I can't figure out how to do it through CLI.

Thanks in common

I also encountered exactly the same problem as you. Mine is the remote ec20 4G lte module.

Problem with uqmi and/or autoconnect. Change temporary proto from qmi to 3g, set net apn, connect, change proto back to qmi, should connect.

1 Like

Is this a bug? When did it appear? I remember it was good to use before. Was it caused by a recent software update? You mean to switch to the 3g option first. Then after setting the APN and account password information, do you switch back to qmi? Do I need to reset the APN and account password in the qmi option?

Just try connect via 3g proto. Modem should remember new apn and you can switch back to proto qmi, with new apn/user/pass etc.

Canyou explain how to switch the proto please.

Does not distinguish any 4G module model? It can be common?

Only for modem supported by uqmi in OpenWrt

i have a Sierra Wireless MC7455 is that compatible?

however i tried your recommendation but it doesnt work.

  1. ifdown A1net
  2. changed proto in /etc/config/network to 3g
  3. ifup A1net

And then back to qmi same procedure

Also tried it in the LuCi interface.

And set proper interface. Not /dev/cdc-wdm0 but /dev/ttyUSB0/1/2/3 or whatever it allow you to connect.

So i set the device to /dev/ttyUSB2 in EDGE/GPRS/EV-DO and got connection with my private APN.
But when switching back to QMI Protocol and choose /dev/cdc-wdm1 i dont get a connection.

If you're looking for a great modem support consider using this OpenWrt-based firmware

Why /dev/cdc-wdm1? Show

ifdown wan
uqmi -d /dev/cdc-wdm0 --get-signal-info
uqmi -d /dev/cdc-wdm1 --get-signal-info

Does this (also) work on 19.07.2 ? As I have problem, not to get IP when trying to use QMI with MC7455:

Hi!

Just taking a chance here. I see you guys are at least able to use UQMI at all.

I attached a Huawei e8372 dongle and am able to see in the logs that OpenWRT detected and a new interface was created.

However, UQMI is not working. I tried:

uqmi -d /dev/cdc-wdm0 --get-signal-info
uqmi -d /dev/cdc-wdm1 --get-signal-info

Saying “failed to open device.” :frowning_face:

Regards,

Vince

Ehh, Huawei e8372 is NOT qmi device. See https://www.rdeeson.com/weblog/179/gsm-internet-on-raspberry-pi-using-huawei-e8372-wifi-dongle , looks like normal hilink device. Set proto=dhcp and proper ifname.

Thank you sooooo much @cezary! I have been battling with this for several weeks thinking I am doing something wrong this certainly boosts my confidence again :smiley:

As a follow-on (hopefully last) question does this mean I cannot use scripting to send text messages and stuff? :frowning_face:

Sincerely,

Vince

Hilink has its own API for this. If this device is compatible with this API, you should able write some script.

Hy,

heres a screenshot of the result from the commands.

Im getting signal on both but however connection to internet im only getting with cdc-wdm1 and only with dynamic APN on QMI.

With Modemmanager i can't choose either wdm1 or wdm0. It only says "Sierra Wireless MC7455" and also with Modemmanager both APN are working Private and Dynamic..

With QMI i can only get a internet connection on wdm1 with Dynamic APN but not with Private APN.

Yesterday i upgraded my Firmware of the MC7455 to latest version.

Still the same problem...