[Solved] Upgrade from 18.06.1 to 18.06.4 and lost web access

Dear all,

I have a tp link w8970 running on 18.01 with web access and I wanted to upgrade to 18.04.

I downloaded the file and went online. I kept the config files

after upgrade and rebooting I can't reach the router via web but still on port 22. The router is working fine with same configs as before. What has change is the access.

Can someone help how to restore it via SSH?

a port scan shows the router on 192.168.1.1. has port: 22, 80, 1194, 4430 open

cheers

UPDATE

after checking the luci.essential howto I managed to change the port for Luci as follow:

uci -q delete uhttpd.main.listen_http
uci add_list uhttpd.main.listen_http="0.0.0.0:8080"
uci add_list uhttpd.main.listen_http="[::]:8080"
uci -q delete uhttpd.main.listen_https
uci add_list uhttpd.main.listen_https="0.0.0.0:8443"
uci add_list uhttpd.main.listen_https="[::]:8443"
uci commit uhttpd
/etc/init.d/uhttpd restart

it works on port 8080 but the it doesn't recognize user and password whist still valid to have access on SSH. I tried several time to time the password also with cut&past. works in SSH not online

next step update?

Have you kept any backup from before the upgrade?
Also keep in mind that packages added after the flashing of the image are not carried over to the upgraded version, so you'll need to reinstall them.
Check what is running on port 80
netstat -lnp | grep 80

2 Likes

Well,
As I was going for several changes on the setting and as first time I worked onopenwrt ending on almost saturating the memory with tests and several extra packages, I decided to go for a full reset via serial console.

I just uploaded the 18.04 without any format of the memory.

Surprisingly the directory /etc/config hasn't been deleted which helped on restoring most of the settings but keeping some of the trouble

At this stage most of the memory has been freed but I have problem on changing lan IP settings.

I have now online access (with old user &password) but when I try to change the IP and save the conf roll back to default 192.168.1.1

I'll open a different post as things have changed from the subject of the title

Cheers

If you don't want to continue here, mark this topic as solved and edit the title with [Solved}.

I made few more tries and I'm seeing this to be a bug somehow

Possibly all issues started when I wanted to change lan ip subnet from /24 to /26...

At the moment I have access using default IP setting 192.168.1.1

I did flash via Luci without keeping configs which reset most of the setting but not all (WiFi parameter were still as before, PPPOE was deleted as example)

I tried to change LAN IP to 10.0.1.0/24 via Luci but the system reverted all time (18.0x feature if browser lost contact to the admin pc, apparently)

I changed the network config file and restart network service. No Luci access, yes SSH access so roll back to 192.168.1.1. all working again

Although I flashed via Luci and not keeping the config something is kept and this can cause the problem when changing IP...

Any hints about which conf file is kept and/or where to look at?

I'm considering backing up the /etc/config directory and undertake a new flash via serial console....

Cheers

Make sure the web server is bound to all IPs uci show uhttpd | grep listen_http

https://openwrt.org/docs/techref/sysupgrade

 Files to be preserved depend on the following:

    /etc/sysupgrade.conf - customizable backup configuration.
    /lib/upgrade/keep.d/* - system configurations provided by specific packages preserved by default.
    opkg list-changed-conffiles - list of files derived by package manager.

You can run firstboot from the SSH or Restore Factory Defaults in Luci. No need to flash again.

1 Like

Ciao @trendy,
thanks for your time.

I just did a default reset over Luci and first thing I tried to change was the LAN IPs. Same situation :frowning:

Uhttpd shows 0.0.0.0:80&443 so it should not matter the lan address

:wave:

So uhttpd is not running on port 80?

Ciao @trendy,

sorry for late reply.

I have access via web so far at the defaut ip of 192.168.1.1. When I change to 10.0.0.0/8 (more or less) i can't access online anymore but I can over SSH which show the intranet is ok...

I'll try on different private IP 172.x.x.x to understand if something has to do with the 10.x.x.x/8 or not

revert soon

cheers

At the moment I've updated using SSH the ip to 172.x.x.x, restart network service and everything is working.

I believe there is something stored somehow in the system which is not reset with factory reset process and give problem to the uhttp and the address 10.0.0.0/8

cheers.

Use something realistic, like 172.16.0.1/24 or /23 if you need more IPs in the same domain.
10.0.0.0/8 is anyway not a valid IP address, setting aside the fact that this can hold 16million hosts.

Thanks for the comment.

I used normally a /24 subnet. It was only a way I thought to be faster typing.

Cheers

[SOLVED]
At the end, after several checks and attempts I figured out it was a problem with browser cache redirecting to the wrong configuration https VS http and https/https standard 80,443 ports VS not standard ports

cheers

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.